[macOS] Virus ?

Hi all,

I booted and work for one hour or so with High Sierra and my left arrow of the embedded Keyboard (of the MacBook Pro) I use works fine.

Conclusion: I get a virus (certainly).

20 years ago (before macOS X), I knew where to search and will find easilly what to remove in my System folder, but now ???

Any hint ?

Yes, I would like a hint…

So your left arrow works fine and your conclusion is you have a virus?

Can you perhaps describe the problem you are having with a bit more care. I don’t think there is any way to provide helpful advice based on what you’ve written so far.

Press the Left Arrow Key and nothing happens, sometimes the Mouse Cursor skip two characters).

Imagine that you have in the Finder (or the Explorer) to make a simple change in hundred of items in a window and you have to fight with the keyboard to place your MouseCursor and make a change *. :frowning:

The symptom is: your LAK does not works reliably.

I recall a “special small software” who rewrote a word with a typo, 30/35 years ago. It was fun for those who watched the affected people to rewrote the word and discover the typo minutes later (fun for 5 minutes after that…).

  • Sometimes, you cannot automatize items renames.

BTW: it is not an easy task to explain a basic “failure”.

Did you try another keyboard?

On the second read I am wonderingÂ…

Problem: The left arrow key have troubles (running on El Capitan).
I wanted to lauch XCode, so I booted on High Sierra and after sometimes, I continued to make some work in a large folder and between others, I make massive renames that I cannot automatize.
After one hour or so, I noticed that the Left Arrow Key apparently works fine.

Conclusion #1: after more teesting, I am now sure I do not have a hardware failure on the use of that key.

Conclusion #2: until I found a bad software, I probably have some application that bugs my Left Arrow Key.

Now, this may be a virus, a bacteria, a troyan, whatever name is not important (for me): I only want to remove what bugs me.

And as I wrote above, there are rooms to do these.

Set Channel: Off Topic.

No. This idea comes to mind a minute or two while I was writing the first answr above !

My mind was set to “my keyboard is broken”, I do not was in bug squashing mode.

The question now is “where my Bluetooth external keyboar is in my room ? (and will it work ?)

Remember: I use a MacBook Pro. I am quite sure that if I used a Desktop computer I certainly had the idea (probably).

Thank you for the advice Ivan.

PS: Option-Left Arrow and Cmd-Left Arrow suffer from the same behavior :frowning:
I even started to use the top key (in the Finder Rename process) to go to the start of the item name. :wink:

Boot the El Capitan OS with the Shift key down to boot into safe mode. See if the left arrow works then. If it does, then it is a software problem. If it doesn’t then we can’t draw a conclusion yet.

You can also try resetting the pram and smc controller, you can google for the procedures they are easy to find.

If it still doesn’t work in safe mode after resetting both those, then my inclination would be hardware related somehow. There are issues with keyboards for certain model years more so than others.

[quote=492236:@Emile Schwarz]Firefox? Yes!

I fired it (last version)Â…[/quote]
HmmÂ… you fired Firefox? Is that not doubling each other? ?

What do you mean by “strangely”? Occasionally working? Typing something else? Making your house to explode?

May not be Firefox’s fault in all cases, you know? ?
Some years ago, someone I know had a problem with her MacBook computer: typing would hardly work correctly (most of the times, nothing would be written in documents/fields or arrow keys would produce “unexpected” (before understanding) behaviours like jumping to parts of texts), starting the Mac in safe mode (using the shift key) would never work (always producing a “normal” start), as well as other start up combinations, clicking would often result in a contextual menu being shown (this was the clue: the ctrl key was being seen as kept-pressed by the OS (and by the computer, since it also affected safe mode inability)).
I guess you can assume it wasn’t Firefox’s fault ?
The “control” key was just stuck, at the hardware level.

Mac and year? It sounds like it might be the butterfly keyboard failing. I have a couple of keys on my 2015 MacBook that do this, but it’s not covered any more. So I may as well buy a brand new Apple laptop than get the keyboard replaced. There’s only $70 difference in price.

1 Like

This is an old topic (last post was in June 2020) that was resurrected by the original author deleting a post. It’s probably not a relevant thread any longer.

1 Like

Anthony is right.

But I consider this as a bug. I deleted a sarcastic (bad) entry, I do not add information.

Now to go back to the question, I think I can gave more data to explain / deepens the matter.

  1. When I booted on Hgh Sierra (this night), I noticed a behavior change: Finder only (clean boot after a PRAM reset, no application running, no internet).
    The “offending” key (left arrow) worked a little better: it needed a clear pressure (not a brute one, but a bit more time than others).

  2. Sometimes, none of the four arrow keys worked; I was in need to use Shift-Tab to move the items selection (in the Finder). Then the arrow keys works once again.

  3. I have a slowdown in the whole computer when I run Firefow/activate Airport (I can see the available Hot Spots), then a bit more slowdown when the internet is connected (I can check my mail / go to web sites).
    Blackmagic Disk Speed Test also displays these changes.

  4. The use of EyeTV (a DVB software) in conjunction with file downloads (Firefox or/and JDownloader) makes the laptop fans to be more noise than AC/DC (the Australian musicians). And th overall slowdown continues.

  5. Sometimes, I cannot achiev the correct download with FireFox, but JDownloader works fine. The slowdown is IMHO in cause.

  6. My Lenovo (booooo, hissss) crashed years ago (no second computer available), and I cannot compare. I will try to loan an old MacBook Pro to do so.

  7. A window cannot be displayed (anymore) a part in the standard external monitor and the other part in the internal monitor: one of the two parts always disappears… :wink:
    But I can display things on the external monitor (usually the DVB TV window).

And since some days, I started to fire Xojo (2015r1 / El Capitan) and it is slow too. This is new compared to last June.

Is it because of my MacBook Pro hardware ? A software cause ? An infection ? One thing is sure, it is not COVID19 :wink:
And neither of the available vaccine will help me about this problem too :wink: