MacOS Sandbox testers get wrong receipts

I know this is a question for Apple - but I rarely get a response there. I am trying to test In-App-Purchases (IAPs) using Sandbox testing accounts but seem to get a situation where the wrong receipts are loaded into my test app.

So, for example:

  1. I create a brand new Sandbox test account in appStoreConnect.
  2. I take my test app and remove the receipt (if there is one).
  3. I run the app and Sandbox prompts me to Sign in to use this application…which I do using the new test account.
  4. Once running I see a new receipt is loaded, which I check and confirm that no IAP’s have been loaded.
  5. Then I request Restore Purchases (from within the app). Checking the receipt shows IAP’s added to it that have not been purchased by this test user.

This makes testing of IAPs very difficult.

Does anyone have a way of really clearing out previous IAP’s from an app?

So I deleted all the Sandbox testing accounts and created new accounts. Reloaded the app and same thing happens. On load it has a receipt for the app. After restore IAP’s it adds one receipt - which happens to be a free IAP. Is it possible that free IAP’s are always downloaded - but that doesn’t seem to be the case as the date on the free IAP is from a previous download.

There are multiple problems with the App Store receipt problem and the Sandbox, in Catalina there are also issues with App Store Kit overall, which will prevent certain transactions from happening.

Some of this is locked to the machine, if creating a new Sandbox user doesn’t solve the problem, then you need to use a different machine and a different account to test with. If you use the same account, the problem then rolls over to that other machine.

Unfortunately getting support from Apple in regards to App Store receipt testing, will just result in pure frustration. There are many unanswered posts in Apple’s forum over sandbox receipt issues. If you use one of your DTS tickets (you get two per year), DTS will tell you that it’s not an issue that DTS can assist with, and that the department who can, do not deal with developers. It stinks.

The only thing that kinda worked for me was to create a new account and use a different Mac. I accidentally used an existing account with that machine, and the problems then rolled over (so I had two machines that I couldn’t use for testing).

I used a third machine running an older version of the macOS, and thats when things just worked, even with the broken account, so perhaps make sure your second machine is using an older version of the macOS.

Thanks for the response Sam - glad I’m not completely gaga. I have just tested with Mojave and it seems to work fine there.

I spent 11 days earlier this year working with DTS in trying to get my IAP application to Work on Catalina, during that time the engineer didn’t believe me that there was actually an issue, until I sent him GBs of log data.

I really had to fight much harder than I should have had to do. This was with a brand new 16" MacBook Pro too.

2020 has been a terrible year for tech.

1 Like

I’ve not had a single issue with Apple’s developer support (even back when we were “enterprise” level) that either didn’t start with “we can’t duplicate” or “that’s the way it should work” as the initial response. Back in the good old days, we had a live liaison who would go to bat for us, but that all died with the $99 developer pricing …

I recall having discussions with DTS in the past, even over minor issues filed via Radar. Now it’s “Feedback”, it’s just a black hole. Occasionally I’ll get a message from DTS, but most of the time the message it’s self doesn’t make any sense. One case got closed with “Apples and oranges”… Like seriously!

I hope I’m wrong but I see dark times for us XOJO users after this change to ARM Processors, I hope I’m wrong but I don’t think so !