MacOS Monterey beta 12 and Xojo

Upgraded from MacOS Monterey beta 11 to beta 12 and Xojo won’t quit (freezes on closing) and neither will my apps without a crash report - insufficient resources.
Just an observation, this is not my development platform, but I like to prepare early before each new OS. A worry if they don’t fix it before final release. It’s been good until this beta release.

Low memory or disk ?

Please file a bug report about this.

Thanks, I have already sent an error report through Feedback Assistant.
Plenty of disk space and 16gb RAM so I don’t understand why this is happening.

FWW there is no beta 12 for Montery. The latest developer build is beta 9

And I do not see the crash here running beta 9

1 Like

I think Craig means from “ macOS 11 Big Sur” to “macOS 12 Monterey” :wink:

Probably but it was confusing because he wrote ‘MacOS Monterey beta 11 to beta 12’. :slight_smile:

Nevertheless: I do not see this crashing with Xojo UI or Xojo compiled apps here.

Yes, confusing.

Sorry for my version error it’s Build 21A5543b.
I should have also added it’s Mac M1.
Quit Xojo and it closes but still appears active in the Dock.
Force Quit to get crash report. If it’s not happening on your machine don’t worry about it. It must be something at my end but I haven’t changed anything with Xojo just run the Mac update last night and instantly couldn’t close Xojo.

It was in Big Sur, but I get some troubles with macOS and M1 recently:
Get Info, Click in Icon, Copy does not worked.
Shutdown. Boot and it worked again.

No issues here on my MBP Intel and MBP M1

I have been running Monterey on an Intel iMac for a month or so and have not seen this behaviour.

Could you check those beta numbers? I’m looking at Apple’s website and the latest is Beta 9.

Have you installed the latest update that came out a few days ago? I didn’t have any problems until now.

When I close Xojo the project closes but the Xojo menu bar remains. I cannot click on any items in the menu including the Apple menu.
Right click the Dock icon to Force Quit.
Part of crash report refers to hang event -

Command: Xojo
Path: /Applications/Xojo 2021 Release 2.1/Xojo.app/Contents/MacOS/Xojo
Identifier: com.xojo.xojo
Version: 21.2.1.53890 (21.2.1.3.53890)
Team ID: 6MG2NQJ3FZ
Architecture: arm64
Parent: launchd [1]
PID: 1029
Time Since Fork: 71s

Event: hang
Duration: 40.38s
Duration Sampled: 1.10s (process was unresponsive for 39 seconds before sampling)
Steps: 11 (100ms sampling interval)

I’m referring to the last beta update this week. Sorry I got the version number mixed up with the OS number (see above).

I upgraded Monterey to beta 9 today and yes, I have had both my debug apps and non-Xojo commercial apps give a crash error when quitting.

Can you post the relevant section of the crash log?

1 Like

That’s good news - kind of :slight_smile:

1 Like

Yes Firefox produces a crash report on closing sometimes as well as Xojo and Xojo apps.
I’m glad someone else is experiencing the same thing. Maybe Apple will notice and fix it themselves if popular apps are going down too.

1 Like
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.