Mac IDE adding smart quotes - how do turn that off?

When I tried out some code writing in the latest IDE (2015r2) I was puzzled to see that whenever I typed text into a TextArea’s Text property, it would turn any regular double quote character into a “smart quote” character, i.e.


turns into


Even worse, while other apps that do that offer a command under the “Edit” menu to turn this off, I found no such in the Xojo IDE. But whatever - I’d expect that a programming tool would not even do this by default. Yet, the IDE does. Am I the only one seeing this or do the Xojo engineers really think this is a good idea?

Its a system wide behaviour set in your user preferences
See System Preferences > Keyboard > Text


Oh System wide. Now I get it.

But why? We’re not using a word processor here. Even Xcode doesn’t use that setting.

I have “Use smart quotes” turned on, but am not seeing them automatically applied in the Xojo code editor. Could this maybe be language-related?

Paul, that might be. I’m using German locale on 10.10.3.

It’s not language related - try this:

Create a new desktop project. Add a constant to the window. Type something in the “Default Value” field of the inspector panel that has quotes. They’ll change to smart quotes.

I noticed this a few days ago when editing some sql that is stored in a constant. I had to resort to writing the sql in a different text editor (jEdit, in my case) and then copy/pasting it into the inspector panel.

NSTextView doesn’t have the ability to set an initial value in the Xcode IDE.

I too think that all properties under Text Checking and Substitutions should be Off for the property Text in the IDE.

I misread Thomas’ original post. The smart quotes do get substituted for TextField/TextAreas, even in the IDE. Smart quotes are not substituted in the code editor.