Log into mySQL - NOT Community Server

Log into mySQL - NOT Community Server
My hosting provider provides me with mySQL databases. They use IP white listing to control access.
I’ve written a PHP script (and installed it on the server) to test my username, password, database name, table name, etc. I can connect and return rows, no errors.
Using Xojo, I can use the PHP HTTP example xojo_binary_project to access the PHP script via a DataSocket.Get(URLField.Text) action and it returns exactly what the script should return.

Now I want to just access the mySQL server directly without PHP. My hosting provider has given me all the info I need except how to set up Xojo to access. It seems every example I can find uses community server. My mySQL is not community server.

From a Windows or Mac OS desktop app, it just seems like I should be able to interact with my mySQL database (return data sets only) but the only plug-in I can find is community server. Please advise.



What have you tried?

The MySQLCommunityServer plugin is the right one to use. Please try it.

You are correct. I needed to add the port and now it works.
Tried it on Windows 7, a laptop running windows 7 and connected to the internet via an iPhone hotspot, and Mac OSX, all compiled.