Locked project is loaded without visual warning

I locked a project, its parent folder and loaded that project in 22r1. Xojo says nothing until the project is fully loaded. I do not tried to modify it.

this screenshot says nearly all:

I was awaiting a locked icon at least below the project specs.

Nota I love to see the offline projects as greyscale entries ! I do not have that hard disk handly, so I do not know if they became black (“loadable”) when the HDD is online (without Xojo reload).

You can file a feature request for that, they may be able to add the locked icon to the file to show on the list. Like this:

I tested this with Word and there is no indication that the file is locked before loading. Once it loads Word shows this:

It could be handy if the locked icon shows on the recent projects, just as now the missing projects are greyed out with a warning icon but for me is enough what Xojo does if I open a locked project and try to modify it:
I was just trying to move a Label when the message appeared.

Edit: I just noticed the locked icon on top of the web project:
It will be nice if the same icon shows when loading the recent files (if it is not too much work, for some reason Word doesn’t show the locked icon either)

Honestly, I do not used Word for the last 35 or 40 years. :grinning:

After OpenAt(x) this thread, I tried to use the project and all I get was beeps (pressing the keyboard). But because I locked the project On Purpose to know how the new version behave, I was not surprised.

What I suggest is simply pushing the grey idea a bit farther; but it would be nice (same to add a Locked Icon in the right part of the description, same window, below the creation / modification dates). It will be a nice information to get, in the case one want to load by mistake a locked item (no time wasted while the project is loading).

Now, there are times when one lock a project to avoid saving modification by errors. THIS IS a different matter, and the lock icon is also welcome in that case.

For the record, apps like TextEdit (and, I guess, other Mac apps) do exactly the same. You don’t know whether the file is writeable (you may see the padlock on the window’s proxy icon, only when the lock is on the file, of course) until you try to modify it and see a similar message.

1 Like

You are right, but it does not have a window like Xojo (the screen shot above), so this is a banana vs orange compare. Note that I love both fruits.

This will complete the current window state (unless someone comes with another idea).

The next idea is here:

It’s a Get Info on an example project (Greg shared it yestrerday). It have ToolbarExtensions and App. But it is nice to know.


I was talking about a window inside Xojo that let you load Recent Item(s); YOU CANNOT SEE ON DISK the icons of these Recent Items when this window is displayed.

An unusual situation. Of course, once loaded, a Cmd-click (or Right-Click) in the window title allows to display the owning folder (and I use that a lot *), then you can see if the project file is locked or not.

  • Is there the same feature on Windows 11 ?