Little Clock

Hi, guys,

I am trying to create a little clock app using the

In a desktop application, I have an HTMLViewer with this code

me.LoadURL ("")

For some reason it just shows blank background with no clock.

Any suggestions?

Thank you,


What OS and what version of Xojo?

I just tried with Xojo 2019 R 3.1 and used the Native render and Webkit on Windows 10 and both showed the clock

HI, Brian,

I am using Xojo 2019 R3.1 on macOS.

Just tried it again. No luck so far.

Just to make sure that I have not missed something, I created a PushButton and placed the same code into the Action (me was replaced with HTMLViewer1 of course)

Still the same result

I compiled the app. On Windows and Linux machines it shows the clock, on a Mac it just shows white background.

Tried it on several Macs in the office to rule out a problem with a specific Mac. It does not work on Macs, works on a web-app though.

Very strange.


I can try this evening on my Mac

I have no Mac to test on at work

I think that could help: :wink:

Found here:

Change http to https

Hi, all,

Sascha and Alberto are correct.

After I replaced the original code with this one, the Mac version became functional.

me.LoadURL ("")

Thank you very much to all for help.