In the current project, and under conditions, I have amask for a date (YYYY-MM-DD):

Listbox.ActiveCell.Mask = "####-##-##"

This works as expected, but… yes BUT:
I can select the to last digits to change them, et. (?)

BUT: If I want to change the two last digits for the year (say change 1931 to 1965) by selecting these two last digits of the year part (or the two digits for the months), Xojo refuse to allow me to type the two digits enforcing it by a Beep (or two ?)

I spent some minutes to read the Mask entry in TextEdit (I think) and I do not saw anything to do.

Nota: I have a trick that allow me to disable / enable the Mask trick, but the name of the software is “Easy Displayer”, not “Hard to use Displayer” :wink: or :(.

Ideas are welcome. TIA

What I think, is that when you select the 2 digits the program doesn’t take into account a number exchange, so when you try to type the first digit you already have the max digits possible.

Maybe Xojo can change the behavior. If no numbers are selected then yes, no other number/character could be entered, but if 1 or more digits are selected, then allow that many digits to be entered.

It looks like the mask is checked first, then if numbers are selected to change the values. It could be best to check the mask and if a number is selected, allow another to change the value of that one. I hope this is clear and sorry I don’t know any way to work around the current behavior.