Listbox.Border: possible bug?

Listbox.Border = False now not only turns off the outer border rectangle of the listbox but also the line between the heading and the first row. I consider this to be a bug. What do you think?

Workaround: draw the line in CellBackgroundPaint for row = 0. You must draw with y = 1:

g.DrawLine(0, 1, g.Width - 1, 1)

… as drawing at y = 0 will not work. Note that therefore the interior of the first row now will be 2 px smaller than the interior of the other rows – and this is noticeable.

Windows? Mac? Version of Xojo?

Mac, but since the listbox is not a native control and all drawing is done by the Xojo framework I assume it is the same for Windows.

Sorry, with “Listbox.Border = False now…” I meant the current release.

I just tried it on Windows and I am not seeing any difference, between 2015r3.1, 2016r1.1 and 2016r2. I may not be doing what you are though. If you can post a small project in a DropBox account, I can try it tomorrow morning, just heading to bed now.

I do most of my work on Windows, but can try it on OS X.

Start Xojo v2016r2
Create a desktop application
Add a listbox
Set HasHeading to “On”
Set Border to “Off”

Result: The line between the heading and the first row is gone.

I confirm for both Xojo 2016 releases (r1.1 & r2; I trashed 2016r1).

More strange is if you add separation lines… (I do not add text in the header… too late I already quit !)

On Windows, I don’t see a difference. What version of OS X, on initial look, I am not seeing it on 10.9.5.

10.11.5 here


You should file a bug report, may be related to 10.11 looks like what I would expect on 10.9

I added a comment to Feedback entry 42610, as it seems to be same error.

Are you sure? That Case deals with the separators between the individual headers. I thought you were talking about the line between the header and the first row?

Maybe it is just my system but I don’t see the line between the header and the first row unless I draw it myself. And it doesn’t matter if I have the border on or off.

I’m running 2016R2 on Windows 10.

Dale, I’m on Windows 7, I’ll try it on Windows 10 later tonight.