ListBox.Addrow Doesn't Add a Row

Xojo 2021r2.1, MacOS Mojave

I have a ContainerControl which is embedded by code in a TabPanel. The ContainerControl has a control subclassed from ListBox. The ContainerControl has a method called Load, which executes ListBox.Addrow with a few string parameters, but no rows are ever added. I can step through the AddRow statement and the LastAddedRowIndex parameter of the ListBox remains at -1.

I’ve verified that all the parameters are strings.

I tried just using AddRow without any parameters, but LastAddedRowIndex still doesn’t change when AddRow is executed.

I tried casting my subclassed ListBox as a ListBox (as shown above), but that doesn’t help. My subclass does not have an AddRow method overriding the super’s.

I created a test project trying to recreate all the conditions, but the test project works.


I was loading the ListBox and then embedding it in the TabPanel. When I change the order so that it’s embedded first and then loaded, it works.