Linux - Virtual Box - Remote Debug

I have Linux Mint running on my iMac in Oracles Virtual Box. There I have Xojo installed.
If I start the remote debugger in Linux it gives me the IP address
I put that in the “Run Remote” dialog in the OSX version of Xojo, but it “fails to connect”
is there a problem/issue with doing “remote” debugging between a “real computer” and a VM?
This was the only reason I installed Linux at all, was to test with

No, that’s what most of us use VMs for.
Something must be disconnected in your setup somewhere. I’m not a Linux expert, so this is where my advice ends :frowning:

Yeah… I’m no Linux person at any level… just trying to find things is a PITA… and I’m sure there are all kinds of utiltiies, but no clue where they are… I don’t know if there is a password I need or not… if there is… it doesn’t work , and the error message is so helpful :slight_smile:

I use either Parallels or VMWare for this very reason. In my experience the Virtual Box networking model is just to fragile for remote debugging.

I run Virtual Box on a Linux host and have run the remote debugger down into Windows and Linux VMs. Most of the issues deal with making sure that the firewall is open for the communications to occur between host and VM.

With virtualbox I add a host-only network (vboxnet0) to each VM. It becomes available in the remote debugger setup dialog (have to choose it from the popup) . I haven’t had any issues since I started doing it this way. Various flavors of mac/win/linux all working well. Plus, it doesn’t break if I’m off my home network.

being unemployed for the last year… investing in either is out of the question

Kevin, Jim… I have NO idea what you just said… like I mentioned above… no clue how to even FIND this info in Linux, let alone change (or even know what to change)

for whats it worth… I have an old MacPro running Win10 under bootcamp, and I can and have been using remote debug with it for years.

It’s in settings - network. Choose the type of ‘LAN’ you want to use. NAT, bridged … Bridged will use same IP address range as your host uses (eg. 192.168.x.x) so it’s easier to connect. Only setting in there you really need to choose from, is when there’s more than one network adapter. If you use a special firewall program with your guest os you’d need to add the needed port there too. I use both VMWare and Virtualbox. Sadly there’s no legal method to use Apple OS X in such virtual machines. So several linux flavours and windows versions only.

Well… I don’t see what you describe.
I did find Networking
there is shows a selection of

  • Wired
  • Network Proxy

Wired shows IPv4/6 addresses (of which the IPv4 is what I told the debugger),

nothing about NAT bridged that I see

And I am running Linux UNDER OSX, not the other way around, so ther eis no legality involved

In the VirtualBox settings for the VM, I recall there being a way to set the networking to Bridged (like Thomas mentions above) that needed to be set in order for remote debugging to work.

Paul… :smiley: I was looking in MINT, not VBox… I just now found that and trying to figure out the right settings (Bridged Adapter IS one of the choices)

Still no joy… The IP address on the Linux side of the debugger did change, so I changed it on the OSX side, but no connection still
I tried with and without the password. Linux says it is listening on port 44553

VBox settings

Attached to : Bridged Adapter
Name : en0:Ethernet
Adapter Type : PCnet-Fast III
Promiscouous Mode : Allow All
Mac Address : #########
[X] Cable Connected

ok… Color me stupid…
All this time I told OSX the IP for the VBox was
and it was in fact … made a HUGE difference :