Linux version is unusable on PClinuxOS

Using the latest Xojo on PClinuxOS mate. This is beyond frustrating. Even creating/editing the most simple apps are a major chore due to the IDE being SO slow. I click something to select it, and I have to wait for the selection to show up. It’s like that with everything. Trying to move an item is a royal nightmare.
Please tell me there’s a way to make this purchase worth my money, because as it is, Xojo for Linux is completely useless to me.
It starts up very fast, but then totally craps out. I have a fast system with lots of RAM, so the issue is definitely not hardware…especially since everything else I’ve installed runs flawlessly, including windows apps.
After doing a search on this problem, the results I found were very discouraging. Please help.

Have you tried one of the supported versions of Linux, rather than PCLinuxOS? I’ve found Mint works pretty well, although I’ve had trouble with the Mate version so I stick with Cinnamon.

I try various distros every so often, but I never like any of them…including mint and the others mentioned. I always end up coming back to PClinuxOS. Thanks for the advice, but doesn’t it seem rather obtuse that I should have to change my OS just to accommodate one single app, especially when there is a generic installer provided? In all these years, I’ve never seen a linux app that required such a thing. It’s going to be pretty pathetic if I have to run another OS in a VM just for xojo. What a waste of space that would be. This doesn’t speak well for xojo at all.

I think directly supporting six of the top 12 distributions on Distrowatch is phenomenal. Not to mention three variants of Raspbian.

I personally prefer Slackware, but use Mint for Xojo compatibility. You prefer PCLinuxOS. I guess we’re both out of luck

Well well well…
I needed to adjust my partition sizes, and increased the swap size in the process. Guess what? Xojo works considerably better! It’s still not ideal, but at least I can work with it now. PClinuxOS had set my swap to 1.5gb, which I increased to match my ram (16gb). I may try increasing it a bit more and see what happens. Thank God for Gparted on a liveusb!!!

It seems I might be wrong about the larger swap making the difference. “free” shows the swap isn’t being used at all (as in: 0) while Xojo is running. It doesn’t seem logical, but could increasing the /home partition have done it? Found out I set the partitions reversed when I installed… /home should have been labeled /, and vice-versa, which ended up with /home only having 3.99gb free after installing some apps. When I fixed all that, Xojo started working much better (almost as well as the windows version). Could that have anything to do with it?
Regardless, for whatever reason, Xojo runs pretty well on PClinuxOS after all. Guess I’ll go wipe the egg off my face now. :wink:

@Bill Dawson - I suspect that you will see the performance lag after a few debug runs. <>

I did notice that as you said, but it took awhile to start happening and close/restart gets things back to normal. At this point, I’ll take what I can get until (if) a better resolution comes along.

Yes - further evidence of a memory leak. When you start working with larger projects, you will see the slowdown occur after just a couple of debug runs. One of my projects drives the IDE’s real memory use to over 3.2GB from just over 900MB after 4 debug runs. Restarting gets me back down to around 900MB.

It happens even on small projects. Why would memory be an issue when I have 16gb? Does the leak really get that bad?