Linux Build under 2017r3 fails Error 32512 Linking Executable Errors

Hello all.

I did a new install of Linux Mint 18.3. I have Xojo versions 2017R3 and 2019R1.1 on it. I tried to compile a console app in 2017R3 and get 109 32512 errors. I try the same code in 2019R1.1 and get no errors.

In other posts they discuss file permissions. I (think) I have set them all to read/write/execute using the GUI. But no change to the output of 2017R3. Can anyone tell me what I have missed?

BTW, before I reinstalled Mint 18.3 I did not have any issues with compiling. Only now with a new install of 18.3


Did you sort this yet?

Hi Tim,

No I have not gotten this sorted yet.

Are you still running 18.3 or have you updated to 19.2? I’m not having issues in 18.3, either.

Still 18.3, I went back to this since i had trouble with 19.2 and no time to mess with it.

I must be missing something in this new install of 18.3…

I’ll spin up a new machine and see what steps I take to get to success and report back (as you know, it’s storming here, so timeo on my hands).

Yes it is storming and I absolutely LOVE IT!
Thanks for your efforts!


Here’s what I did:

New Xeon 3.2GHz
Nvidia 1650Ti
2TB Seagate disk

Installed default Mint 18.2 image
Ran updated and installed the “MintUpdate” tools
Re-ran the updater and did the full upgrade
Installed the 440 Nvidia driver
Installed 19r2 using DEB
Installed 19r1.1 using deb
Installed 18r3 using deb
Installed 18r1.1 using tgz
Installed 17r3 using tgz

Ran 19r2 - simple project builds and runs
Ran 19r1.1 - same
Ran 18r1.1 - same
Ran 17r3 - got 32512 error 4 times (actual error is 127 which means execution failed)

I validated (and fixed) a few execution bits in Xojo Libs, but I still get the same error. Something’s definitely off with 17r3. Ill check with CentOS and Ubuntu a little later.

Double checked and the same TGZ install of 17r3 runs and builds properly under Mint 19.2.

In my previous install of Mint 18, 2017R3 worked perfectly. Don’t know why it would suddenly fail to be kind…

Thanks for doing all of that. I’ll check my install to match what you have.