Linux-App startet nicht

Von einem Anwender habe ich die Info, dass meine App unter Debian 9 nicht startet. Ich habe hier in einer VM Debian 9 installiert und meine App im Terminal gestartet. Das ist das Ergebnis:

parallels@debian-gnu-linux-vm:~$ ‘/home/parallels/Familienbande/Familienbande’
/home/parallels/Familienbande/Familienbande: error while loading shared libraries: libunwind.so.8: cannot open shared object file: No such file or directory

Ich selbst habe keine Ahnung von Linux. Die Version ist also eher ein Nebenprodukt. Kann mir jamand mit Tipps weiterhelfen, die ich an den Anwender weiterreichen kann?

Gru, Stefan Mettenbrink.

Hi Stefan,

schau mal hier https://docs.xojo.com/Resources:System_Requirements unter Linux Notes. Die Bibliothek muss der Nutzer manuell installieren.

sudo apt-get install libunwind8

Ich hatte dort nachgesehen und nur das gefunden:
[i]32-bit and 64-bit versions of Linux are supported.

Linux Mint 16 or later
CentOS 7.0 or later
Ubuntu 14.04 LTS or later
Debian 6.0 or later
OpenSUSE 11.3 or later
Fedora 13 Desktop or later

For best results on 64-bit distributions, build a 64-bit app. [/i]

Da habe ich nicht weit genug gescrollt :frowning:


Ich habe mal nachinstalliert und gestestet:
parallels@debian-gnu-linux-vm:~$ sudo apt-get install xserver-xorg-core
[sudo] password for parallels:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
xserver-common
The following packages will be upgraded:
xserver-common xserver-xorg-core
2 upgraded, 0 newly installed, 0 to remove and 56 not upgraded.
Need to get 0 B/5,436 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs… Done
(Reading database … 148959 files and directories currently installed.)
Preparing to unpack …/xserver-common_2%3a1.19.2-1+deb9u5_all.deb …
Unpacking xserver-common (2:1.19.2-1+deb9u5) over (2:1.19.2-1+deb9u4) …
Preparing to unpack …/xserver-xorg-core_2%3a1.19.2-1+deb9u5_amd64.deb …
Unpacking xserver-xorg-core (2:1.19.2-1+deb9u5) over (2:1.19.2-1+deb9u4) …
Setting up xserver-common (2:1.19.2-1+deb9u5) …
Setting up xserver-xorg-core (2:1.19.2-1+deb9u5) …
Processing triggers for man-db (2.7.6.1-2) …
parallels@debian-gnu-linux-vm:~$ ‘/home/parallels/Familienbande/Familienbande’
/home/parallels/Familienbande/Familienbande: error while loading shared libraries: libunwind.so.8: cannot open shared object file: No such file or directory

Kein Erfolg :frowning:
Eigentlich hatte ich die Systemvoraussetzungen so verstanden, dass ich mit Debian 9 keine Probleme habe und auf eine Nachinstallation verzichten kann.

Hat noch jemand eine Idee?

Ach ja, wer selbst mal ausprobieren möchte, die App findet sich hier:
http://www.familienbande-genealogie.de/Test/fblin.zip

Gruß, Stefan Mettenbrink.

Man muss schon richtig lesen und die richtige Bibliothek installieren.

sudo apt-get install libunwind8

Hat dann auch bei mir geholfen.

Danke!