Links to Feedback case do not work most of the time

Hi,

when there is a link in a post, for example https://forum.xojo.com/t/is-this-side-effect-of-how-picture-dimensions-are-reported-deliberate/58547/4 (4th post), most of the time clicking on the link opens Feedback but then it doesn’t display the case it should do, in this instance 62545. Feedback displays the last case under the CASES list . If I search for 62545 then I get this:

I can’t click on the second line to have it displayed. I use Feedback 2018r1.1 and that seems to be the latest version.

What is going wrong ?

Thanks

1 Like

I’ve seen this same issue for many years on both Linux and Windows. It usually works on macOS.

You can always type a case number into the Search bar at the top of the Feedback window. Press Return and it should display that case.

I have done that, see the screen capture. But then afterwards I can’t get into the details of the case.

Odd. Here, I see that summary line for a fraction of a second (long enough to see that it is a summary line), then the case opens.

if you have feedback not open yet it sometimes doesn’t load the links.
If you have feedback open and loaded, links should work normally.

For sure there is a bug in feedback.

Tried that and I got

image

We need something that works :worried:.

@Greg_O_Lone Anything you know about that ? Thanks.

That dialog probably means that Feedback is already running but is hung. Look at your task list and quit and instances of Feedback that are there and try again.

True. What I did is start Feedback from the icon, it open and worked fine. Then I clicked on a link and after a few seconds I got the same message, but Feedback is not hung as far as I can tell.

I checked the Windows log, noting in there.

EDIT

I made another test. I launched Feedback from the icon, typed another case, 62698 in this case, and this time the data as depicted in my screen shot and shortly after the case was fully displayed.

I wonder if it has to do with:

  • It’s because Feedback has already been open before, in that case you do not need to login the other times
    AND/OR
  • Some cases are badly formed and this brings Feedback in an unstable state.

I use macOS Catalina.
When I click a feedback link in the forum while the feedback app is not running yet, the feedback app will open. But, it will not go to the case number I clicked.
When I click the link in the forum again, now with a running feedback app, the right feedback case will open.

This might be due to the way the feedback app opens. It launches with certain arguments. Of course, it authenticates with my credentials. Maybe the arguments are not stored, to be used later after the login routines finishes.
When the app is already open, authenticating is not needed and the arguments are dealt with, so the right case opens.

But hey… I don’t know the inner workings of the feedback app. And since the web-version of the feedback app is in the making, my guess is that these bugs will not be fixed, I think…

Tried something something else this morning. Feedback has not been started yet.

  • In a thread I clicked on a link to case 61510
  • Feedback started, I logged in and case 61900, the last one under CASES open
  • Then I clicked on File > New Viewer Window
  • A new windows appeared displaying case 61510 !

Looks like when Feedback is first launched being told to open case 61510 it can’t, for an obscure reason, but remembers the case to open. And then asking to create a new window, Feedback now succeeds in opening the right case, with the right case being the last under CASES. And then If I do again File > New Viewer Window, I get a case number that comes from nowhere.

Is that what’s called fuzzy logic :crazy_face: ?

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.