Lines drawing incorrectly

Hi !
Just switched to Xojo 2014R3 from 2013R2 release. Opened projects are working, except one important thing: Drawn lines appearing placed incorrectly by chance, see links to images below.

I can’t reproduce this behaviour in a reliable way. Sometimes it is working on one window, then the lines are appearing misplaced next time debugging the project. When compiling a project, lines are still misplaced on OS X and Windows - but on different windows.

I tried to move affected lines a bit (just guessing that this would help), called Line.Refresh() or adjusted the width a bit in Window.Open event - nothing works. When opening the project and going through all windows, then debugging or building the project, all lines are correctly handled. But I have to “view” each window in the IDE before at least one time. And next time opening the project, it’s refusing drawing the lines correctly again.

Anybody out there knowing a fix or at least has an idea what is going wrong there ? Any quick replacement for lines ? Maybe the technical support of Xojo reads this and is able to assist ?

Otherwise I have to return the newly ordered license, because not working classes is a knock out criterion and makes this purchase useless (compared to 2013R2 release, especially since I’m using lines quite often in projects).

Your links don’t appear to be in the post.

Oh, sorry. Here they are:

Not working:

How it should look like:

IIRC this happened with 2014r1. I’m sure there is a feedback report on it. I just dropped a couple of lines I was using which behaved like this. Look up the feedback report and see if it’s scheduled to be fixed.

Nope, but it sounds like it’d make a good bug report. Please attach a project which reproduces the issue.

@Joe: Even if I would do so, this doesn’t really solve my problem. A feedback case is of no help. We all know how long it may take till things are getting fixed even a feedback case exists for.

If Roger is right, this seems to be known since 2014R1 already. And unfortunately this issue is nothing that can wait till next release. As it appears now, either I have to find a replacement for the lines or switch back to my old release 2013R2. Wasted time.

Please excuse when I’m appearing a bit angry, but I just can’t believe that such basics things have not been better tested before. Line is such a basic class. :frowning:

[quote=153300:@Tobias Eichner]@Joe: Even if I would do so, this doesn’t really solve my problem. A feedback case is of no help. We all know how long it may take till things are getting fixed even a feedback case exists for.


Use a Separator instead of a Line Control.

@Karen: Thanks for the suggestion. Even I’m appearing a bit pedantic, but the separator can’t get a different colour which I need in certain cases (although mainly for layout purposes).

I already thought about creating my own line class based up on a canvas. But I must confess, that I feel this will be much work with little effect finally. Must think about if this is worth the efforts.

Can you switch to a rectangle instead? Just make it 1 pixel high or whatever…

I just ran across a similar problem not too long ago. I think it’s an IDE issue, maybe having to do with opening projects created with an older version of RS/Xojo.

I’m not at my dev machine right now, but have a look at all the properties of the line object in the Inspector, and make sure that Left, Top, X1, X2, Y1, Y2 ALL make sense. My recollection is that the Y2 value wasn’t the same as Y1 after opening an older project, even though the line was horizontal in the older version IDE, and drawn as horizontal in the new one.


@Bill: Just finished writing my own small line class… now I sleep about if it is worth implementing it in about twenty active projects I currently maintain (roughly estimated about 200 times…).

@Peter Truskier: No, this isn’t the reason. For example I have a line there with these settings:

Left: 35
Top: 292
X1: 35
X2: 915
Y1: 292
Y2: 292

All values are making sense to me. But you may be right, all projects have been created in earlier releases of the IDE, most of them with RB.

Nice, really, really nice. Windows builds are tending to crash when windows containing incorrectly drawn lines. :frowning:

What happens if you delete the line and add it back? Do they start behaving again? What format is the project? Binary, text or xml? If binary, try saving as text or xml and then opening it again.

@Tim Hare : Problem persists even when lines are deleted and added again. All projects are in binary format.

I tried saving in both, XML and text - the problem persists.

Cant recreate.
How about change these to a g.drawline command in the window paint event?
It should be doing the same thing…

Sometimes I get really weird behaviour like this. If it isn’t a corrupted project then clearing the cache and restarting the computer usually fixes it. Might be worth a try.

@Jeff Tullin: Thanks for the tip. I wish I could say the same here… this bug appeared in all projects so far (must say that all actual apps have been created with RealStudio, but I worked on them with Xojo 2013R2 successfully without problems).

I’m tired to find out the reason why all this happens, this is not my job and I don’t have the time doing so. For $700 I expect a stable product, especially since Xojo claims to be a professional development tool.

Well, my final solution: I’ve created a custom class based upon a canvas and now will manually update all projects. Much work for nothing. But at least “line locking” now works with my class, it was a bug in the line class since eons of time.

But hey, I can’t understand why I’m so upset, finally it was my fault. How could I just think that switching to another Xojo release would be a flawless procedure… not learned from history. :frowning:

Please excuse if my posting appears a bit offending, but I’m currently quite unsatisfied with the quality of Xojo.

Anyway, I appreciated your hints on solving this issue, thanks again to the community. :slight_smile:

@Markus Winter : I could understand if one project was affected… but all ? What do you mean with “clearing the cache” ? At least rebooting doesn’t help.