LIfeboat

Can we also use this forum to ask questions for Strawberry Software - Lifeboat?

My client bought it for me. I wanted to ask few things.

1 Like

I don’t see why not, while I don’t actually use Lifeboat, it is one of the most impressive Xojo Add-Ons available at the moment. Tim has done great work for it and it gets fantastic reviews.

2 Likes

I’m always happy to answer questions about my tools! :slight_smile:

What can I help you with?

2 Likes

Hi Tim,

I am using IONOS web hosting provider and I use centos.

I successfully upload my xojo without domain name. but I am wondered, how to see if its running? I tried to type the IP: PORT in browser address, but nothing happened. site not found.

should I need to have domain name for this to work?
should I need single exclusive IP address for each xojo web app?

Please help.

Hi Ronaldo,

The way Lifeboat configures a server, everything is handled by name. You may use the server IP address but you must configure it as a “domain” on the Domains & Subdomains view. This way the server knows which web app to route IP address traffic to.

Some things to know about using an IP address instead of a domain name:

  • You aren’t able to issue SSL certificates for an IP address with Let’s Encrypt
  • You can do this for only one web app per IP address

The best way to use Lifeboat with multiple apps on one server is with a domain name. The tutorial video here shows quickly how to set up a domain so that you can create any subdomain within Lifeboat.

Hope this helps! Please let me know if you have any more questions :slight_smile:

Best wishes,
Tim Parnell

Maybe someone can help me with this problem:

Xojo app
Using Lifeboat
Using an Amazon Lightsail server with Linux
Using GoDaddy for domain names

I had my app deployed and could use it online but the set up wasn’t right - something about the domain names was messed up and my SSH certificate was incorrect, leading to security warnings.

I started the progress over again, but not Lifeboat is returning an error when I try to use it to log in.

"Server Managed Elsewhere

This server has a Lifeboat configuration from another system. To avoid configuration conflicts please connect from the system that configured this server."

When I look at the files on the Lightsail Unix server, the install seems to be using an IP address which might have been the previous IP for my home machine until my hosting changed it which they do since my IP is not static?

Anyway, is there a way to uninstall Lifeboat off the server to start fresh?

Unless you have done a lot of other stuff to the VM, I would delete it from Lightsail and create a new VM.

Yeah that’s what I ended up doing to get it to work. I just had to carefully download my data files so data wasn’t lost.

I’m sorry to hear you’re having trouble with Lifeboat! From the start Lifeboat has been a mostly one-way system. Lifeboat writes the configuration and then sends it to the server. If the source data on your machine for Lifeboat is different from that of the configured server problems can start to arise. During early testing there was a “take over” feature, but that seemed to have little success so it was removed before public release.

My personal recommendation if you’re starting over fresh is to use a whole new server to ensure there aren’t conflicts. Especially because configuring the server outside the realm of Lifeboat can lead to conflicts sometimes. It’s best to let Lifeboat manage the server configuration by itself.

To trick Lifeboat into thinking the server hasn’t been configured yet (if you really must) you can delete the “base camp” folder it sets up. That is located at ~/.com.strawberrysw.Lifeboat (where the tilde expands to your home folder path). Lifeboat will ask you to install if this folder doesn’t exist.

If you have any further trouble please feel free to reach out by email directly, that way I can offer hands on support should we need to explore an issue more in depth.

Hope all is well!

Best wishes,
Tim Parnell

3 Likes
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.