Lifeboat - Testing Ubuntu and other service providers!


I have been working on an app to simplify the deploy process for Xojo Web apps. My goal is to help everyone who wants to make a web app get up and running. Ubuntu support is looking good and I’m looking for help testing it!

Lifeboat build 18 is available now with support for Ubuntu 18.04 LTS. This is available on both AWS Lightsail and DigitalOcean platforms. I would love feedback from folks who aren’t using those providers, as Lifeboat should be able to deploy to any Linux CentOS 7 or Ubuntu 18 server.

Here’s what’s changed since build 16:
New: Support for Ubuntu 18.04 LTS
New: Connect to a server with the enter or return key
New: Can now reboot server with button
New: View Logs button for discoverability
New: SSL History button for discoverability
New: Checks server is 64-bit when connecting
Fixed: Deleting a server now removes it from the server menu

Download links:

Best wishes,
Tim Parnell



There’s an issue in build 18 where if your home folder doesn’t have a “.ssh” folder you will be unable to create a new server connection. This has been corrected for the next build. If you’d like to get up and running with build 18 you can work around it by creating a “.ssh” folder in your home folder.

This applies to both platforms, but you are far more likely to have that folder on macOS than Windows. Fork creates this folder on Windows, so I thought it’d be a nice-to-add. Unfortunately, my code is catching the wrong type of exception. :upside_down_face:

Thanks for checking out Lifeboat!

Tim, this looks awesome! I am going to build a test on DigitalOcean, and will be using a Windows PC to run Lifeboat18.

Will let you know how it goes…

ooops - I’m stuck…

I had to use puTTyGen to create new Private / Public key files, but Lifeboat always displays an error message "Unable to extract Public key from Private key.

What am I doing wrong? (puTTyGen is all at its default settings)

To use a key pair generated by PuTTYGen you’ll need to export it in OpenSSH format.

Thanks Tim, I tried that, but still getting the same error.
I also tried the second option (force new file format) - still same error.??

Could it be something to do with my Win10 laptop? I am using an Administrator account.?

FYI - I am able to login to the DO server with PuTTY using the private key created with PuTTYgen.
But I cannot find any way to connect using Lifeboat

I have created the export file for OpenSSH and I can load that file back in to PuTTY.

I also tried using ssh keygen. This generated 2 key files - one has no filename extension, the other has .pub extension. But Lifeboat always shows same error message, whichever file I use.

1 Like


I’m very excited to test out my new exception reporting system I call Radar. Hopefully nobody runs into any exceptions! This build also fixes the issue with needing to have a .ssh folder in your home folder.

Here’s what’s changed since build 18:
New: Server group caption now indicates flavor
New: Lifeboat hides itself when disconnecting before quitting (macOS only)
New: Lifeboat will attempt to warn developers when the webapp address does not resolve as expected
New: Exception reporting with Radar
Fixed: Updates messages now display on non-English systems
Fixed: Windows issue with default key location
Fixed: Rare NilObjectException caused by server dropout
Fixed: Raw text window close button locking
Changed: Moved server control buttons into server group
Changed: Added details about OpenSSH key format to user guide
Changed: Web app validation errors are now attached to the window

For those wondering, we did resolve Tony’s issue connecting :slight_smile:

More info:

Download links:

Best wishes,
Tim Parnell

Yes - Lifeboat is working very well for me now. I have successfully uploaded some test webapps (including apps with sqlite db’s) - all running smoothly on a Digital Ocean droplet.

I have a new question for Tim:-
So far, with Lifeboat, I have mapped a subdomain to each app, ie: => webapp_A => webapp_B

I have some use cases where I want to locate multiple apps on a common subdomain, ie:

Is this possible to do in Lifeboat? What would be the procedure?

The way Lifeboat configures a server each app will need a subdomain.

The nginx documentation makes it seem like what you want to do should be possible, but Lifeboat is not designed to configure nginx in that way.

I did just confirm that you can use with Lifeboat though. You could do:

Thanks Tim,
That makes sense.