Lifeboat: non-lowercase domain names w/SSL and Server Load display

Question 1: I tried to set up SSL-enabled domain with a mix of upper- and lower-case letters, but Lifeboat encountered a (gracefully handled) error and couldn’t set up SSL on the domain until I made the entire name lower-case as a random guess of what might be causing the error. Is Lifeboat protecting me from an SSL issue I’m not aware of, or should SSL work for a mixed-case domain? If the former, then I humbly request that a verbose explanation for the situation be added to the error message explaining that domains can’t be mixed-case. If the latter, consider this a bug report!

Question 2: Are the three numbers shown next to “Server Load” basically the typical Linux ‘last 1/5/15 minute averages’ for the processes with 1.0 representing capacity or are they something else? I couldn’t find anything in the documentation.

Most importantly, Lifeboat is awesome! I’m VERY glad I bought it last week!

1 Like

Lifeboat should be passing what you entered as a domain directly to certbot. I will have to look at this and see if there’s something I can do to make this process more smooth. To be quite honest, I don’t think I’ve ever tried mixing case in a domain!

If you captured the error I would be really grateful if you could email the details to me directly

Regarding the Server Load, yes those numbers come straight from Linux uptime command. Thank you for checking the documentation! I will have to add a note about the server load somewhere :thinking:

I’m so glad you are having success with Lifeboat and are pleased with the app!

I’ve sent the screen shot to you! Thanks again!