Lifeboat: Database Connected Elsewhere


While I was away, my computer apparently crashed (it was again at the login window). Went back to my session and Lifeboat won’t run anymore. It says:

Database Connected Elsewhere
Lifeboat is open and syncing this database with (my user name) on (my computer).

(where my user name and computer are the same as the ones I’m trying to reconnect from).

I can’t even get to any window, nor read the help (since the app won’t open). Hints welcome.

Search your computer for lifeboat.db and next to it should be .Lifeboat.lockfile, you need to delete this lock file.

Search here /Library/Application Support/com.strawberrysw.lifeboat/

Thanks for your answer. However, I don’t have this file there:

Maybe it is a hidden file? .lifeboat.db

ls -a on terminal

I checked for that. The preview above shows hidden files (you may notice the leftmost one is an hidden one).


Thanks anyway.

sorry that it did not help
Hopefully @Tim_Parnell might have an Idea

And no sorry did not notice you already checked for hidden files as I’m on phone and forgot my glasses

No problem. You were trying to help, and that’s what matters.

Thanks for pinging me to this thread.

This message is when Lifeboat thinks your Super Simple Sync database is open elsewhere. You can erroneously get this message if Lifeboat is not quit by normal means (such as a crash). You will find the .lockfile Alberto mentions in your Super Simple Sync folder, not your Application Support folder. Delete the invisible lockfile.

This system was invented to avoid collisions with two people trying to use Super Simple Sync on different machines at the same time. It’s called super simple for a reason :slight_smile:

For what it’s worth, you can find the user guide for Lifeboat online if that’s ever an option. I did include it inside the app as well so that it can be accessed offline.

Hopefully this helps get you going again, please let me know if you need any more guidance.

Best wishes,
Tim Parnell

1 Like

@Tim_Parnell @Arnaud_N

Answer from the creator , hope you get it solved :smile:

I’m sorry my edited post push you to search for Lifeboat.db in only one location. I should have left my post with just the original first paragraph.

Let us know if you find the .lockfile

there are no apologies needed when trying to help


Thanks for your reply.

I’ve been searching for both “Super Simple Sync” and “Lifeboat.lockfile” in my whole library folder (with an app I made, which can search with criterions, like in Mac OS classic; I know the app works), but haven’t found any.
We’re speaking about the Library folder inside the home folder, right?

Yes, I understood :wink:

Yes, please.

Thank you.

No problem. With my application to search for files, I searched thru the whole Library folder (inside my home folder) for the lock file but there was no result. So no location looks to be correct (? :thinking:). Thank you.

Did you tried the one in System ?
(I’ve just made a search for a folder called Library and they are a ton of them when you include “system files” in the search…)

I didn’t try, because it should be a per-user file (imagine if two users on my computer were to use Lifeboat; they’d have each a separate file). Now I tried, but same result.

I don’t use spotlight to search. The app I made searches item by item, so missing them theoretically can’t happen.

Thanks for your answer.

No, this problem is inside the folder you selected for Super Simple Sync. Generally, this is inside Dropbox, OneDrive, or whatever cloud service you’re using to sync.

Here’s the user guide page for Super Simple Sync that describes the lockfile:

Maybe your lifeboat.db and .lifeboat.lockfile are not on your computer?

Do you have Super Simply Sync active?


You need to go to that folder, and check for .lifeboat.lockfile

1 Like

Hmm… I’m not syncing anything, not using DropBox, iCloud or whatever. Probably the reason why “Super Simple Sync” doesn’t ring a bell to me.
Sadly, I can’t even launch Lifeboat to check my settings, but I’m not recalling I did chose an option to sync.

Edit: I’ve just noticed the .Lifeboat.lockfile in my iCloud documents folder. Can’t figure out why it went there, as I’m not syncing things with iCloud on my computer (and the file wouldn’t appear in a local folder). :man_shrugging:
If you have an explanation, I’d like to read it.

I’ve deleted that file and it worked! Thanks for your support!

Now that I regained control of Lifeboat, I’ve verified, and the checkbox is checked, indeed. Could it have been an option automatically turned on? Otherwise it looks like I checked it too fast :man_shrugging:.


You should have the lifeboat.db file that Lifeboat is using in that folder too.

It is not automatic because we need to select a sync folder.

I have one there, correct. One of the reasons of the troubles I had is that there’s also one in Application Support (but no lock file there), so I focused on that folder by mistake.

Ok. I’m not sure whether I chose this option “for experimenting” or because I thought I needed it. Whatever…

Thank you.