LifeBoat - Can't Launch App

I’ve uploaded my Web App’s Linux build to a LightSail Debian 12 server, and LifeBoat has successfully set up the stuff. Status shows as Inactive in LifeBoats’s Web Apps listbox. When I select it and click Start, Status briefly shows “Transitioning” but goes back to Inactive after a second or so.

The app runs fine in debug mode under MacOS at It was built under Xojo 2020r2.1.

I’ve entered my server’s IP address in Domains and have SSL disabled.

What am I doing wrong, @Tim_Parnell?

Usually this happens when your app crash and can’t recover.

I have seen that (for example) when I forget to create the database that the app relies on.

1 Like

Hi Julia, I received your crash report too. I plan to try to replicate it, but I had additional questions I was going to send you once I ran my tests. Be on the lookout for an email about that one!

When you Right-Click on the app in Lifeboat and select “View App Logs…” does it show anything of interest?

Alberto is correct, this usually happens when the app fails to launch for some reason. Also calling App.Quit can cause this if you use App.Quit in your error handling. Sprinkle Print("Did step 1") throughout your App.Opening to help debug where the code may be exiting. Messages sent out through Print() appear in the Lifeboat “View App Logs…” logs.

(I can send you one of my built test apps if you are just trying out Lifeboat and want to see it work)

1 Like

The crash was apparently due to having uploaded the app’s components in folders - once I stopped doing that, that issue went away.

Maybe the inability to launch is because I built for x86? Should I build for ARM instead?

View Logs reports Log file does not exist.

Lifeboat should show you which architecture your server is in the details on the left hand side of the window.

If your app is Web 2.0 this means that the app has never successfully completed the App.Opening event, which prints a message “Application is ready” once that event finishes.

Yah, it’s x86

If you’d like to send the App.Opening code for a quick glance review, you are welcome to do so however you feel most comfortable. My direct email address is

Stupid user error here. I’d copied code over from a previous project that was for RaspberryPi and it quit from Opening if the app couldn’t be demonized :sheepish: All working now, thanks for the quick responses!

1 Like

So glad it works!

I’m going to try to break things with a nested-folder drag-n-drop, but that was supposed to have worked as well :innocent:

1 Like

I think this is what I drug-n-dropped when it crashed:


…the entire “Linux 64 bit” folder.


@Gilles_Plante, it was intentional, for humor :slight_smile: “Drug” is (incorrectly) used as the past tense of “drag” in some parts of the world, e.g. “Look what the cat drug in”