Launching iOS App in debug mode from Xojo IDE

I just buy a Pro licence to launch my first Xojo iOS App on the AppStore. I test successfully my app on simulator. But I can not test my app (or any other sample app provided by Xojo sample) to my real device. I already read documentation and configure Xcode, developper account etc.

I can easily run a my Xojo App From from Xcode on my device.

When I try to run my Xojo App from Xojo IDE I have the following message. I have the following message :

Since we could not locate the target IDE to start a debug session, this application will now exit

Any idea ?

First, please make sure you’ve selected App Store instead of development in the IDE build settings. It’s a subtle but not obvious requirement,

Also, make sure your device is plugged into your computer. WiFi debugging does work, but it’s very picky the first time.

Thanks @Greg_O

I do not have AppStore on stage Code

My device is plugged with a USB wire and I still have the same error :frowning:

It’s in the iOS build settings, not Shared.

I still have the same error this not the solution

I found the solution in the “Certificates, Identifiers & Profiles” of my Apple Developer account. I selected all my devices including my Mac, previously I had only selected my iPhone. Apparently, that wasn’t enough!