Launch Screen Image doesn't change

I’m working on a new app. The name I chose was already taken in the App Store so I’ve been updating all my icons and images to reflect the new name.

In a Launch Screen I’ve got a MobileImageViewer that displays an image that I’ve changed. It shows correctly in the IDE but when I run the app the old image is displayed in the LaunchScreen.

I’ve completely replaced the MobileImageViewer, deleted the image from the app and created a new one, and even tried changing back to iOSImageView temporarily. The image shows correctly in the IDE but not in the Launch Screen when I run.

Anyone got any ideas? Thanks!

I think the launch screen is cached by the device.

Did you try deleting the app then installing it again?

1 Like

Or ‘Erase all content and Settings’ in the simulator device?

The wrong image is displayed in both the simulator and on an iPad.

Completely deleted the Launch Screen and rebuilt it. Still not fixed in simulator. Then erased all content in the simulator and it fixed it. Built the app and it is now correct on the iPad.

1 Like