Kaju 2.1 stuck on Processing file


I tried to use Kaju version 2.1 on an app. As the app is API 2.0, I modified fields to build the project.


  • Application by DesktopApplication
  • Window by DesktopWindow
  • App.YieldToNextTread() by Thread.YieldToNext()

I was using Xojo 2022r2 and was on macOS BigSur

I checked using debugger and app is correctly downloaded in a temporary folder but nothing happens after, Label on self-updater window is saying “Processing file…”

Thank you

I think something else must have changed from the original project. Can you diff your code against the original and see if there is, perhaps, a Timer that is now default Off or a Shell that is supposed to be Asynchronous, or something like that?

Thank you, I will try to look into it but there will be a lot of diff I think with the changes of API version and Xojo version.

I encountered exactly that problem and found that executeAsync is missing an event call. Works for me this way:

Public Sub ExecuteAsync()
  // Uses the new socket to check asynchronously
  // (required for newer certificates)
  // The caller should be prepared to handle an exception in case of error.
  If Not PreCheck Then
    RaiseEvent ExecuteAsyncComplete
  End If
  FetchAsync false
End Sub
1 Like

Hello, sorry for the late answer but tried this and it changed nothing and it’s still stuck to processing file.

I will try to look at differences between the github and the project in API2.0