Issue SMTPSecureSocket - error 102 back again

Hi all - I have been using the SMTPSecureSocket to send email in my app for sometime. Last week, it stopped working in production. Nothing changed on device running the app…
Using the exact same parameters that are totally valid in my Mail app - port, server, user name and password etc, I am now receiving a 102 error as soon as I call the .SendMail method.
I don’t get any call back on the ConnectionEstablished event or anything on ServerError - just straight to Error with .LastErrorCode set to 102.

I’ve been informed that my mail service provider did implement “Grey Listing” but I can’t be sure this is the cause.

As a test, I went and implemented the same function using the same parameters using the CURLEmailMBS class instead of the stock SMTPSecureSocket and it worked straight off.

I have asked the server provider to disable the “Grey Listing” at least temporarily to see if this returns the functionality to the Xojo class…

Does anyone have any ideas, comments or insight?



Does it work with CURLSMBS class?
Any error messages?
Maybe some SSL settings needed?

don’t forget the app security flags :

[quote=452898:@Christian Schmitz]Does it work with CURLSMBS class?
Any error messages?
Maybe some SSL settings needed?[/quote]

Using the same parameters in CURLEmailMBS works just fine. Isn’t that pretty much the same thing?

[quote=452901:@Jean-Yves Pochez]don’t forget the app security flags :[/quote]

Not sure that I understand the relevance of this here and again, the code hasn’t changed and neither did the OS / device it is running on. Can you explain Jean-Yves?

Google changed their policy again** regarding less-secure apps. You may have had your settings updated.

The server I am connecting too had not hosted by Google…
UPDATE: Its not a Grey Listing issues - we turned it off on my email server but I still get 102 error.

seeing this :
102 seems not really an error … you should filter it but if you get the mail send anyway it is not an error.
it just says the smtp server has closed the connexion…

But the the email isn’t being sent. None of the other events are triggered except the Error and 102 is set in LastErrorCode.

What host are you running on? On my Mac, I use PacketPeeper to see what the actual to/fro traffic is. That’s helped sometimes.

You actually have a plist entry to allow (unsecure) connections to ip adresses or hostnames?

Is this a question for me?

No for the TS as he is on posted on the mac forum.