Is Breakpoints broken?

I just updated to the 2018 Xojo release 1 for Mac. Is anybody else having problems with breakpoints for desktop applications… The debugging no longer stops at the breakpoints. Tried multiple different spots. Tried the first line of the open event and it doesn’t stop. Any help would be appreciated.

Yes. <>
Guess there will be a 1.1 release for this.

Thanks for the quick response. Hope they’ll work on this quickly because it completely stops my work. Appreciate the help.

Found this too:

In the mean time, using the command Break in the code where you would place a breakpoint, works. It is far less convenient, but until 2018R1.1 arrives, it is an option. It will not help with remote debugging however. (don’t forget to remove breaks from the code before building the app!)

No need to worry about that. Break commands don’t affect your built application.

Thanks for getting that in guys. Anyone else having colour problems in 2018.1 ?

It would be best to create a new thread on that with a bit more information/explanation/pictures :slight_smile:

I’ve found a way to reproduce 64 bit breakpoints not working - it’s in the latest beta so only some people can see it, but I think it’s the same issue that’s in 2018R1 and perhaps even older.

My example project includes an overloaded method, but I’m not sure if that’s important. It’s been marked as “verified” by Xojo.

Breakpoints, as stated in earlier posts, are seemingly inconsistent in 2008-R1. Working with breakpoints while debugging–seems the program stack also ‘disappears’, or partially disappears. To continue development, dropped back to 2017-R3 yesterday. (Win 7 environment)