iOS & Sonoma

Is anyone running Sonoma and successfully building / debugging for iOS?

When I try to run a new blank project it works fine. As soon as I save it to my computer I get errors about detritus and signing and cannot get it to launch.

I’ve tried both on and off iCloud and with r2 and r3.
I have a MacBook Air 15" M2.

I’m getting a similar issue on Mac OS Desktop builds - signing and detritus, but it launches anyway.

If anyone is also experiencing this and has solved it, I’d love to hear how.
If you are on Sonoma and not seeing this, I’d like to know that too.

Thanks in advance, everybody.

Hi @Chris_Halford,

  • Are your projects saved on Desktop?
  • What version of Sonoma?

On the iOS side, I suppose you have Xcode 15 installed / run and with the correct toolchain selected; also make sure your certificates are current and also keep an eye on the ProvisioningProfiles / Application ID.… although the apps meant to be run on the Simulator should work fine anyway :thinking:

The “detritus” thing is odd if you don’t have iCloud (or other “sync” apps/utilities) messing around with your Documents / Desktop folders…


I have ALWAYS used iCloud to sync my files and it was never a problem before (I know I know… stop yelling everybody!!!). But I know it’s advised against I have tried it in a new folder with .nosync

My projects are saved in a folder on my desktop and I can move them anywhere else that is recommended, although I’ve tested alternate locations and not seen anything different.

I have Xcode 15 and have updated all the certificates and profiles.

I’m going to try to run xattr -cr to clean things up, but I honestly don’t quite know what that is getting and where all to apply it.

Yeah, I know… until Apple change things :person_shrugging:

I just tried this again.

  1. Build an empty iOS app and run in the simulator - no problem.
  2. saved to a folder set with .nosync and run - no problem
  3. Ran again and had the issue.

This is bonkers. I really can’t be the only one seeing this…

and you asked before about OS Version 14.0

You need a provisioning profile, your certificates to be valid, a identifier (no wildcard) with your device uuid in it. And you need to select a team in the ide. Also you cannot just change the bundle id and app name every time. Make sure you use an app name once with a bundle id.

Open xcode latest and make sure to install the utilities cli stuff if asked. Then in xocde select preferences and your account then click the profiles thing to sync. Then go to xcode > locations select the latest and your should be good to go.

All this may help but i don’t guarantee it. I have no issues, but your project file in a icloud synced folder will make trouble for sure.

Maybe you need to restart your xojo ide and/or your mac to complete all steps.

The syncing is more often on changed these days so yes it may cause more issues.

Hi Derk,
The odd thing is that this was all working 100% prior to the OS update, so all those things were in place. I did reset them all though.

I’ll keep powering through.

1 Like


Have you tried @Greg_O 's Profile Triage tool.

I think it’s to help deal with problems like this and I feel like I’ve seen it mentioned in threads where people were having the ever so helpful “Detritus” message.

Maybe Greg will chime in now that he’s tagged.

Sure have. Nice tool.

For anyone who’s contributed here:

My finder totally stopped responding even after reboot.

Reinstalling the OS now.
Wish me luck!