IOS Simulator - Nothing available in Simulator Device PopUp menu

Before I start out I had the worst of all computer problems happen. Despite having some of the best APC UPS systems installed at each server / desktop a recent lightning storm caused massive failure on the iMAC I use for developing. Long story short the power supply, video and logic boards required replacing. I am now at the place where the computer is up, data xferd, applications working and I now need to work on IOS applications. When I opened XOJO and it finally resolved I opened a IOS project and found that I could not debug as no Simulator Device was available in the Pop-up.

Recognizing previous Certs Identifies and Profiles were connected to the old computers MACs I logged into Apple and revoked the old certs, created a new on, associated Profiles and made certain all devices were selected. When that was completed I went into Xcode and removed my account. Then I shut down Xcode (by the way XOJO was not open at this time). Then I opened Xcode again and this time logged into my developer account. All certs downloaded and the correct ones were now revoked.

[quote]In Window - Devices and Simulators a number of devices show and when I connect my iPhone it shows in Device area with correct app info
In Preferences - Components Simulators shows IOS 12.2 and 11.4 are checked and loaded
In Preferences - Locations Derived Data and Archives popup = ‘Default’ and each point to their Library/Developer/Xcode/ sub directory[/quote]

I open XOJO, open my IOS app and still nothing is available in Simulator Device popup menu. I have unselected Code Singing Team in the XOJO app. Bundle identifier is correct. Saved and closed out XOJO. then restarted XOJO, opened IOS app and selected Code Singing Team and still nothing appears in Simulator Device popup menu. I have repeated this with Xcode open or closed.

Anyone know what I am missing?

what version of Xcode are you using ?
That is relevant here

Hmm - is that it. The OS was updated to Mojave in this process by Apple

yeah use 10.2 or 10.3

Oyyeee - Thanks

Was hard to find but located it here in case anyone needs it

Just downloaded Xcode 11 (didn’t realize it was released a few days ago)
But strange that while the iPhone11 is now listed, the iPhoneX, XR and XS are NOT

EDIT : but you can (and have to it seems) add them manually…

More weirdness.

I have downloaded and enabled all updates to Xcode 10.3 build (10G8). I repeated deleting existing account. Quit Xcode while XOJO is not running. I open Xcode. In Preferences create account using Apple ID. Team, User profiles and keys download. Next I create a new project and set Identity and Signing aspects per XOJO Paul Lefebvre guide but using my needs. Then I open XOJO. Set bundle identifier to what it needs to be and select Team. Still no devices are available for IOS Debugging but I can build to new Code Signing and deploy. The run button is enabled and then complains that no device is selected.


Any thoughts?

I have had the same issue with Xcode 10.3 so I reverted to Xcode 10.2.1

Seems this is fixed with the latest Xojo version available to pre-release testers.

@Jeremie Leroy - just completed downloading 10.2.1 and the problem continues. I am now not certain how to resolve

This is how I fixed it

  1. Download Xcode 10.2.1 from

  2. Go to your Applications folder and rename to

  3. Install Xcode 10.2.1

  4. Quit Xojo

  5. Run Xcode 10.2.1

  6. Open Xojo

I have the same problem… Tried with xCode 10.2 and 10.3 but not work. The select box does not open.

I have another system I use for dev work and is setup the same as the desktop. That system is okay with new Apple credentials. Difference is the other system Xcode was always at 10.2.1. There must be some prefes, support, plist files that need to be removed before I install 10.2.1.

I used a reference to uninstalling Xcode but that did not work either. Is there an uninstall for Xcode that anyone could share?