IOS Movieplayer/Htmlviewer

Should both commands basically play the same thing? I get a result from the htmlviewer but not the movie player


What could be potentially stop the url loading into the movie player as I have tried several movies that exist?

Sample Code, what am I doing wrong? Xojo 2022R4.1

I would suspect that it’s because instagram doesn’t allow direct links without an account. For instance, when I go to that link (because I don’t have an account) I get redirected to this page:

That would happen in movieplayer as well because it’s not a browser.

I get the same result if I use the link from the blog in the field

When I go to that url in iOS safari, it tells me that the url is not playable. That would explain this. It simply could be an encoding that it can’t handle.

Another possibility is that the location it is being served from is not sending the correct information to allow streaming. I see that if I download that url, I get the big bunny movie and it does play.

Is there a way to recapture the video from the HTMLViewer and save it plays there?

No. Just download it with an URLConnection and play it locally or use a server that supports this.

OK will check it out. Were you able to get any videos to play in the Movieplayer via loadurl(link)?

Can anyone confirm that MoviePlayer1.LoadURL works? Still no luck with this


well… I’ve still got it working here… here’s the url I’m using from my CDN:

Thanks Greg for confirming, that URL worked. I tried several url’s none of which worked even though they showed in the HTML viewer so I am not sure on the difference maybe back to your other suggestion of an encoding problem.