iODBC on M1 Mac - Plz help running

I migrated to an M1 Mac. I’m trying to launch a project I need to continue to maintain but my iODBC driver doesn’t appear to be working.

It appears as if there is an M1 supported version:

I’ve installed that but it doesn’t work. The error I’m getting from the app is:
[iODBC][Driver Manager]dlopen(/Library/ODBC/Actual SQL Server.bundle/Contents/MacOS/, 0x0006): tried: ‘/Library/ODBC/Actual SQL Server.bundle/Contents/MacOS/’ (no such file)

When I try to run I also get this error:
Screen Shot 2022-08-19 at 11.21.09 AM

But I do see the bundle and file existing:

But the OS keeps wanting me to move it into the trash.

I’ve tried reinstalling the library but it doesn’t seem to put the “/Library/ODBC/Actual SQL Server.bundle” file back, I’ve had to import it from my non-M1 mac, but that doesn’t seem to be sufficient

Has anyone successfully used this driver to get MSSql working on an M1 chip or know an alternative?


You ought to talk to the folks over at Actual Technologies. They’re the experts on this.

what about installing Rosetta??

1 Like

I got it working! I purchased a new key though cause my license key was too old. Thanks to everyone who looked at this. I appreciate it.
Happy sailing for me now :smiley: at least until the next issue haha!