Invalid signature in El Capitan

I’m signing my apps and packages using AppWrapper 3.11.3 and lately I have got complains that signatures are invalid, but not in all OS as it seems to work fine with recent ones.

In El Capitan I’m getting “…pkg can’t be installed because its digital signature is invalid”, but after copying file to Big Sur and testing with AppWrapper it seems to be fine and usable.

Notarization is done manually regarding that this version of AppWrapper is old and throws an error.

1 Like

Just upgraded AppWrapper and it seems that pkg files created with BigSur can’t be used on 10.11 or lower.
Made a dmg and seems to work.

I really hate all this hassle with versions, signatures, certificates and related.


This even stumped Apple’s technical support people for a while. While they tried their best to provide a solution to this, there currently is only two options I am aware of.

  1. Use Catalina to code sign and package your apps.
  2. Use a different archive format, such as DMG or Zip.

Edit: I periodically check to see if Apple have reversed this decision, but they haven’t yet with the beta version of Big Sur I am currently running.


Amen. I’m fighting currently with ARM where stuff is absolutely prohibited that worked for years and years.