"invalid binary file" in the app store


last week I put a new app in the app store and it is sold to some customers.
Today I tried to add an update to the app store, where I only changed some contents of some labels.

After wrapping the app with App Wrapper 3, uploading the app with Application Loader to itunes connect and submitting the app for approval, the build of the app is not further processed by apple. Instead the built gets the label: “invalid binary file”. There is no further information about what is wrong with the file.

Any ideas how to solve this?

I looked for but couldn’t find a link to a video posted, I believe, by Bob Keeney of the creator of BBEdit explaining why he will no longer submit to the MAS. Unexplained warnings such as you experienced were one of his chief complaints. I know that’s no help not you but just to let you know, it isn’t just you. The best I can offer is to contact iTunes support and see if they can tell you. Or just try again.

*Rich Seigel wrote BBEdit
Video: https://vimeo.com/111903901

Double check that you’ve signed with the correct identity.
One of them is for signing Mac apps in general, and one is specific to the App Store.

What version of Xojo did you use to build?
What file did you upload (.pkg or .app?)

There’s very little we can tell you with how little you told us, sorry :frowning:

Definitely not me. :slight_smile:
I submitted an app to the Mac App Store today. Hasn’t gotten rejected - yet.

I once had a rejection with the same reason. Later i remembered i had activated using the same identifier for all components. I just had to remove this checkmark.

The invalid binary also occurs when one tries to upload a file that has the same version number as the one online.

As for the reasons why BBEdit went out of the MAS, I suspect it has more to do with the huge brand recognition and enormous installed base they have that make being in the MAS a luxury. For most people like me, going at it alone is not a valid option.

For my core business I do not depend on the MAS. But it would be foolish of me to drop the extra MAS business altogether. Even if since 2013, the MAS has been going down.

But then you get additional information like “There is already a binary with the same version number.

Thanks to all for your ideas,

I used this script https://forum.xojo.com/conversation/post/233855 to upload the binary and it works when I use the same Version number like 1.0.0 to upload a file. The value in the brackets 1.0.0 (1) is enough to differ between the 1.0.0 versions to get uploaded and excepted in the MAS. I have done that with the 1.0.0 version. Now the 1.0.1 version should be uploaded into the MAS and now I tried 1.0.1 (0), 1.0.1 (1), 1.0.1 (2), and for all there was the response “invalid binary file”.

The settings are the same here, thanks for the idea. The http://postimage.org/ site seems to be cool to share pictures for this forum!

I contacted the iTunes Connect team yesterday.

[quote=242301:@Tim Parnell]What version of Xojo did you use to build?
What file did you upload (.pkg or .app?)[/quote]
Xojo 2015R4
.pkg (never tried to upload .app)

AFAIK the accepted version scheme in the MAS is #.#.#.

I never used a third decimal actually, and I kind of remember App Wrapper to have a setting making sure only two are used (not at my desk right now).

It is possible that the extra number is dropped.

[quote=242301:@Tim Parnell]Double check that you’ve signed with the correct identity.
One of them is for signing Mac apps in general, and one is specific to the App Store.[/quote]
In the “General” settings of App Wrapper, what does it read next to “Code signature”?

Also you’re not storing the app in Dropbox are you?

No, I don’t use dropbox for storing my apps.

Below my name and in green letters: “Good for code & Installer signing”

beside Packing also in green letters: “Automatically enabled for the Mac App Store”

On the capabilities tab:
App Sandbox : App Store Only,
the only checked property for sandboxing is: Use “Inheritance” for entitlements

I havent’t got a response from the iTunes Connct team yet.

Currently it takes em 3-6 days. (Taken from http://reviewtimes.cocoanaut.com/)

I think you’re using the wrong signature.

Can you use the “e-mail support” function in App Wrapper and attach the signed version of your application and I’ll take a look at it for you.

Thanks Sam,

Do you need the .app or .pkg file?

I only have the first rejected version, or the last one that is waiting for approval for some days now.

The app please

Thanks all for your help.

The application is now accepted by apple. In the info.plist file of the accepted binary app are these additional settings. Don’t know if this makes the difference.