installed other program and my stuff doesn't work

I updated a program and it didn’t umm maybe complete. Afterwords, the other program’s icon didn’t show up in applications, so something went bad. It’s a program that runs very much in the background. (I also can’t find the place for startup items) After this install, things in XOJO debugger and my app don’t work. A menu item won’t always function. The up/down arrows don’t always work. Backspace doesn’t always clear things out of a text area. When I debug, and this is going on, the debugger crashes. I ran an un-installer hoping it’d clear things up but it didn’t. Suggestions?

Nobody has any ideas about how to save XOJO? Is there a cleaner or resetter? I do have a backup, but
The program I built doesn’t at a point allow changes to text areas. It also doesn’t allow backspace. This really speaks to “if your program gets on the app store, it passes”, because this other program wasn’t on the App store.

Try reinstalling whatever program you updated and then tried to uninstall? Is Xojo the only affected program? Have you tried removing Xojo and redownloading it?

Thanks. I wasn’t sure if that’d do it. The program monitors hardware items, so I guessed it messed with some of the OSX system.
I redid the whole computer from a recent backup.

I finally got every thing working. I’d also switched to Cocoa, but thought I’d tested that. Something is still wrong. Will have to post differently.