Install problem...

Ok, I have Xojo version 20143.2 (my latest licensed version). I have it installed on two machines, both running Mint Linux 64.

On the one machine it is fine… loads up a licensed version every time. On the other machine, it does NOT save my license or registration info. So each time I run it I have to install my license (and un-authorize a machine) to get it to load the license. I have checked the permissions on each machine, and they seem the same.

Any idea how to get the second one to register correctly?

Also, has the ability to select landscape printing been added / fixed for Linux? I will probably wait to renew my license until this functionality is added…

Thats very likely this bug - <https://xojo.com/issue/40983>
Now why it would show up only on one machine is very odd

Norm,

I can’t seem to follow the link you provided… either chrome tries to open an external file or firefox says not found??

How do I read the feedback issue?

You need to have Feedback.app installed.
http://xojo.com/download/extras.php

Ok… hate to say it, but I am unable to install / run feedback… I run 64 bit Linux, and my VMware (with windows) does not have high enough resolution for feedback… can some one copy and paste the feedback issue here??

Ignore last post… was finally able to get feedback running… I looked at the issue referenced ,but I don’t think that is my issue…

I am not running Linux Mint in a VM… it is my main system. On the laptop it registers the license correctly, but on the main desktop, the license will not register and must be reinstalled after each start / stop of Xojo.

Shouldn’t matter that its a VM actually
The problem is the same whether its in a vm or not

Basically “license not sticking” is the issue - exactly what you’re seeing

Norm,

Ok, I read the feedback… it does not say how to fix the problem? It does say a the end the problem is fixed and verified, but not how it was fixed??

We changed the license handling to address this in the now-shipping Xojo 2016r1.

[quote=257690:@Gary Vassalotti]
Ok, I read the feedback… it does not say how to fix the problem? [/quote]
There is nothing YOU can do
It was entirely in the IDE code which we updated

Out of curiosity - what kind of data do you want to print from the IDE? Source code? Reports? Window layouts?

[quote=257697:@Norman Palardy]There is nothing YOU can do
It was entirely in the IDE code which we updated[/quote]
I think Norman means to say: If you update to the new IDE, which came out today, it should fix your issue.

Have you checked Landscape Printing - General - Xojo Programming Forum ?

The example I posted there enables you to print Landscape.

Note that it uses the default 72 dpi resolution, but Xojo enables you to print at full printer resolution. See http://documentation.xojo.com/index.php/PrinterSetup

Of course it will become necessary to adapt the size of p accordingly by using MaxHorizontalResolution and MaxVerticalResolution.

Oh, you want printing from your code to work, not from the IDE. I missed that. Nevermind my question above.

I did a bit of checking. It seems the issue is not with Xojo, it is with Linux. Since the IDE uses the system Open Printer dialog, if the system does not provide Landscape, it makes sense it is not available.

I googled “Linux Landscape Printing”, there are countless discussions all leading to no simple system solution.