Inno Script Studio for a 32 Bit Xojo Build won't launch in Windows 10

I’m having problem’s with a Windows 10 Inno Script Studio for a 32 Bit Build from Xojo that was working fine on my last build. I’m testing it on my 32 bit HP Notebook recently updated to Windows 10. I used the Inno sample script from the Xojo Documentation with the windows runtime vc_redist.x86.exe. I noticed my new Windows 10 32 bit does not have the Program Files (x86) directory only Program Files. When I launch it I’m getting a Setup Internal Error Dialog: Cannot run files in 64 bit Location’s on this version of Windows. I uninstalled my build and reinstalled it creating “Program Files (x86)” Directory with the select Destination Location in the Inno Setup. I’m still getting the same problem.

The old Windows 7 worked fine with both 64 & 32 bit Program File Directories. What did Microsoft change in Windows 10 and what has to be changed in the Inno script to make it work? My 64 bit Xojo Build installs and works fine.

The only difference that I see in the 32 & 64 Bit Inno Sample Script Xojo Documention is
; 64 Bit has this and 32 does not and the different runtime file vc_redist.x86.exe & VC_redist.x64.exe

The InnoSetup newsgroup is very helpful.

Thank You I did look there and couldn’t find anything. I did find complaints about Windows 10 32 bit app with older hardware install problems with the 1709 Win10 updates in the Microsoft forums with really no solutions. Is Microsoft trying to Phase out 32 Bit.

Did you post a question there about this? Years ago i did that, and got a quick reply.

No I’ll try that. Thank You

Hm…we’ve installed 32-bit apps on Windows 10 using InnoSetup for a while.

If you want to limit the installer to ONLY install on 64-bit Windows you put this in the [Setup] section


Otherwise you shouldn’t have to do anything. It will install your app in the proper locations. You should be using {app} shortcut though so it knows what you mean.

[Files] Source: "Z:\\MyApp\\Builds - MyApp Suite.rbvcp\\Windows\\MyWinApp\\*"; DestDir: "{app}"; Flags: ignoreversion Source: "Z:\\MyApp\\Builds - MyApp Suite.rbvcp\\Windows\\MyWinApp\\ MyWinApp Libs\\*"; DestDir: "{app}\\MyWinApp Libs\"; Flags: ignoreversion recursesubdirs createallsubdirs Source: "Z:\\MyApp\\Builds - MyApp Suite.rbvcp\\Windows\\MyWinApp\\ MyWinApp Resources\\*"; DestDir: "{app}\\MyWinApp Resources\"; Flags: ignoreversion recursesubdirs createallsubdirs

Forgive some of the spaces in the paths. Copying/pasting product names to protect the guilty. :stuck_out_tongue:

Hi Robert

No problem with the spaces I understand. I do have more source files for my Soraco Quick License Manager for Licensing that don’t have Flags “?”. The issue might be with those files. But the prior 32 Bit build worked and the 64 bit is working and the code below is the same.

Source:  "C:MyApBuild\\MyApp.exe"; DestDir: "{app}"; Flags: ignoreversion
Source:  "C: MyApBuild\\MyApp Libs\\*"; DestDir:  "{app}\\MyApp Libs"; Flags: ignoreversion recursesubdirs createallsubdirs
Source:  "C: MyApBuild\\MyApp Resources\\*"; DestDir: "{app}\\MyApp Resources"; Flags: ignoreversion recursesubdirs createallsubdirs

Source: "C:\\Users\\Public\\Documents\\Quick License Manager\\qlmpro\\Windows\\Xojo\\MyApp 1.0.lw.xml"; DestDir: "{app}"
Source: "C:\\Users\\Public\\Documents\\Quick License Manager\\qlmpro\\Windows\\Xojo\\QlmLicenseWizard.exe"; DestDir: "{app}"
Source: "C:\\Users\\Public\\Documents\\Quick License Manager\\qlmpro\\Windows\\Xojo\\QlmLicenseLib.dll"; DestDir: "{app}"
Source: "C:\\Users\\Public\\Documents\\Quick License Manage\\qlmpro\\Windows\\Xojo\\QlmWrapper.dll"; DestDir: "{app}"
Source: "C:\\Users\\Public\\Documents\\Quick License Manager\\qlmpro\\Windows\\Xojo\\QlmWrapper.tlb"; DestDir: "{app}"
Source: "C:\\Users\\Public\\Documents\\Quick License Manager\\qlmpro\\Windows\\Xojo\\register.bat"; DestDir: "{app}"

On a machine you said is a 32bit HP laptop?

This is almost certainly the problem row: (the only thing I can see which differs from your script (or at least the bits you have shown) and the one I use for my 32bit app)

Just remove it for your 32bit build?

Thanks Jeff

I did take out that line. I just found the old 32 bit build file that worked on my old computer and going to install it and see if it works again. I’ll keep you posted.

Ok guys I got it fixed and it was something really stupid. The Notebook Hardware by error was assumed 32 bit (Device Manager had x86) but if would have checked the System it’s 64 Bit. I installed a 32 Bit Windows 10 iso that was allowed to load without a dialog warning of wrong OS.

Thank You for your help