Inconsistent Results From Movieplayer

I have written a small test program for the Movieplayer on Windows and tried it on three systems. All three behave differently.

  1. An old dell laptop plays the .wmv movie pretty much as expected.

  2. Windows 10 home edition running in boot camp on a retina iMac runs it but half size, centered in the Movieplayer.

  3. Windows 10 pro (version 1703) running in VMware on the same iMac does not run it at all. The controller indicates it is running, but the screen remains black.

The windows media player itself runs as expected everywhere.

This behavior is recent. As the saying goes, “it used to work.” Any suggested explanations would be welcome.

Check and see if your test works with 2016r3. That’s before we did the Direct2D conversion.

I am seeing the same results in 2016r3; small in Windows 10 home (presumably my problem) but still just black screen in Windows pro. Has anyone else been successful with Movieplayer in current Windows pro?

Hi James,

I have had similar inconsistent results with the movie player control.

I wrote a movie player with API declares (example 16-4 in the declares book) which worked on VMware.

One other oddity was that I couldn’t have two sounds playing at the same time with the xojo control. Using declares allowed multiple sounds to be played at once.

Maybe this info will help?