ImageView disappears

Hello, i found a strange thing.
On my webapp is an imagewell / imageview with my logo.
It works perfect.
After i inserted a HTMLViewer in the footer, the upper HTMLViewer disappears! everyting is ok.
But after the upload the logo is away.
The logo is in the resources folder. I checked everything.
I removed the imagewell and build it new.
Without result. The imagewell in not more usable.

I solved the problem by inserting an HTMLViewer on top.
It works, but now my graphic icons in the next images are away!!!

At the moment i “repaired” the app with HTMLviewer.
But the mousedown doesn’t work.
So i placed the old invisible imageviews on top.
Now it works.
But what is with the imagewells???

I removed all the HTMLviewer and replaced it with the ImageView.
(That was the original status.)
At all the images are visible.
At the browser/internet the images are invisible.
The images are in the recources folder, i checked the privileges, everything is ok.

Now i have two versions:
1 with pictures via HTMLviewer but difficult to handle (no mousedown event)
2 without pictures, only with ImageViewer

A sample project would go a long way here to helping us help you.

I made a sample, but both ways are working.
It seems that the app is damaged…
I can give you the link to the apps: with ImageViewer, no logo on top / footer with HTMLviewer

Probably too simple. But are the two projects in the same base folder? Xojo does not persistently track the location of the graphic object on the development machine.

Like Greg said a sample f the code would go a long way.

No, different folder.
I think i have to make a new project and copy module by module and then we will see.

Can you share a sample project?

I can tell you that your app on port 1025 it is serving /framework/spacer.gif where the images should be (I used Develop menu on Safari to find that). I don’t know why it serves spacer.gif instead of your images.

I tried to prepare a sample, by cleaning the project, uploading, starting, checking and deleting.
I tried to find out which object caused this error.
But that takes to much time.
So i used an older, working project and updated again. That is less work…
Thanks for all. Solved! :frowning: