IDE Windows incredibly s - l - o - w

I use Xojo Windows. With about 15 Windows, 200 methods and other stuff, the IDE editor becomes incredibly slow. When typing, it takes about 5 seconds for the characters to appear. Using the backspace is virtually impossible. The autocomplete can’t be used while it takes another 3 seconds to appear, and when it appears, it got the words mixed up, double or garbage.

I simply cannot work with this. When will this be fixed?


In the video, watch how long it takes for the characters to appear after the cursor is positioned…

I’ve got the same problem as Alexander. I really hope that this will be fixed soon…

I’m pretty confident this is because they use a canvas as the IDE editor and have to do all kinds of tricks to get it to function as a textarea-type interface. I really wish they would focus on a solution that used a text input-type control instead of what they’re doing now.

I upgraded my Windows 7 machine to 8 GB RAM and it seemed to help a little.

They have to get this fixed or the IDE will be unusable for many on Windows.

I wonder if any of the Xojo developers work on Windows?

We noticed the slowdown using Kapersky antivirus. Switched to a different antivirus solution and the problem went away almost completely.

I don’t use Kaspersky, but I switched off MS security Essentials… no change…

Windows XP, Vista, Windows 7, windows 8? 32 bit or 64 bit? How much RAM? What version of Xojo?
Our main project is 139 windows, 51 modules, 209 classes, 25 interfaces and has over 375000 lines of code.
We do not have the problem I saw in your video. If we did, it would be unworkable.
I’m using a i5-3470 PC with 64 bit Windows 7 and 8GB RAM.

HP Probook 4740s, Intel Core i3, 2.4 Ghz, Windows 7 64 bit, 4 Gb Ram, Xojo ver2013.3. Strange thing is that the slowness not gradually appeared, but just ‘was there’. I’m thinking if this has something to do with 2013.3. I also checked in the running processes if some kind of key logger of hotkey program was active. So I shut down all processes I couldn’t relate to Windows… no change.

Driving me nuts…

how much cpu is xojo using? we noticed that 3 seems to be using more. It’s one of the reasons we are still using 2013r2

Busy with a re-install…:frowning: Fed up with it and your post made me think the problem source is not Xojo.

Laptop given clean install Win 7, Xojo 2013.31 as only program. Problem still the same…Pfff :frowning:

Hmm. International windows version?
It has to be something. Troubleshooting without having the machine isn’t easy :slight_smile:
Don’t get too frustrated, I’m sure eventually someone will help you figure out what the problem could be. It’s definitely not happening on my machine and if it was happening to a large number of users, we would have heard about it loudly on this forum. It’s just a matter of figuring out what the problem is.

It’s an international Windows version that comes with the HP laptop. It installs Windows 7 and an awful lot of HP crap…

Funny… I typed c-r-a-p and look what the forum does with it…

Dutch version of Windows ( I assume) with an English version of Xojo on a HP machine. Other than the fact that it is a desktop machine here and you use a laptop, it’s the same config (but I have 8GB of mem and an i5). Does Xojo also behave like this when you start a new project?

I’ve seen this on my Mac sometimes. Generally quitting Xojo and restarting it seem to work. That or a machine reboot.

going on a limb here: Your spec says 4 GB RAM, which should be enough. Given that there is a lot of “added value” stuff on your computer, much of which may be running in the background, can you take a look at available memory? if your laptop is short on available memory and resorts to virtual memory on disk, you would definitely have poor performances.

Hi Jon,

no… that was the first I tried, several times…

It is a binary project, an xml one, or a vcp one? Also are you using external code? Are you using encrypted modules, plugins?

Could you perhaps create a private Feedback case with your project (and all related items)? It would be great if we could reproduce this.

I just tried Windows 7 x64 on a VM with a single CPU and only 1GB RAM assigned and the full suite of MBS plugins installed. I’m not seeing any slowdown using Xojo as I navigate projects or type in the code editor.

I also stumbled across this Windows performance tool:

I haven’t tried it, but I wonder if it might shed some light on the problem?