IDE under Linux very slow

Under linux mint mate the IDE is unusable slow.
CPU AMD x3 8 GB Ram
Is there a possibility to make the IDE faster?

Have enough Hard Disk free space ?
(around 50GB start to be a good amount of free space.)

50 GB??? To start an IDE?
But yes, I have enough free space. Not the start is the problem, it takes a long time to start, but I can live with it.
The problem is the IDE while runnig. To type a letter needs very long time. To use the arrow keys (or all other keys) needs very long time.

Linux mint mate? I thought ubuntu mate was the only distrp with that name?

No (and this was an error, more or less).

I meant enough space for the OS to live in. In my Intel i3 laptop, if the SSD free space is below 30 GB, the whole laptop performance start to slowdown.

While I am at it, an SSD as the boot device can be a good idea.

That said, slow while typing a character in the Code Editor recalls me something.

What Xojo version is it ?

I’ve tried both: 2017r1 and 2017r2. No difference, both not usable slow.

Which AMD x3 CPU is this ? The 450 ?
What video card is in the machine ?

AMD Phenom II x3 B78, 3GHZ
Graphic: AMD Radeon HD 5450
With this PC I can play fast Carrace-Games ^^
But a IDE doesn’t work :frowning:

that games work isnt really relevant - they push a machine in different ways and may bypass gtk entirely or make minimal use of it for some UI then use something else for the actual game play that does use gtk (unity etc)

how does something like gimp or gedit work on this machine ?
or some of the other apps listed on

they use GTK in ways that are a lot more similar to the IDE

It works all fine, also gimp. Only the Xojo IDE doesn’t work.
I have on the same Computer Windows 10. On Windows the Win-IDE works much better.

I use the IDE on Linux Mint 18.1 Cinnamon 32 and 64 bit
I find it quite reasonable

Cant say i’ve tried mate

Same problem here. Tried a fresh installation of latest Suse Leap and much slower than the last versions of Xojo.
(With versions <2017r2.1 the XFCE was the fastest but after switching go gtk3 it seems impossible to work with)

It really getting frustrating - my employer s paying for half a dozen licences and every time xojo releases a new version it becomes more and more frustrating to work under Linux with Xojo - some of the ‘better’ versions is from 2016.

I request xojo to take a moment for retrospection. For windows and linux builders 2017 wasn’t fantastic so far.

I cannot test Xojo 2017r2.1 because my 20BM partition is full (VirtualBox). I have to delete it and install Mint 18.2 directly (trashing 10.8.1 + all updates since install).


well here it’s not slower as it was bevor (Meaning ist the same slowness as is has ever been on Linux.)

OpenSUSE Leap 42.3 Mate with Xojo 2017 R2.1, MBS Plugins 17.4pr5, ValentinaDB ADK.
–> Real Hardware.
Linux PC Installation: Intel i7-3770, 16GB RAM, 3 TB HDD
an i don’t use the tmpfs RAM trick. Becaus i need to be able tor burn my Backups (to BluRay-Disks) my “/tmp” is actualiy it’s own Partition with 128GB Space…

The only time that I’ve seen a slow down on a properly configured Linux system is when I have 10+ tabs open in the IDE. I use both VMs and real systems. My VMs are all configured with 2 cores, 4GB ram, 1GB Video RAM with 3D support enabled.

One other question - are you manually installing the VM tools for the system? Unless you’re installing the support tools (especially for Fusion), you have not enabled the proper hardware emulation that you need.

Mate (Mat tay) is a desktop environment, not a Linux distribution type. You can install Mate on any Linux and you can also run Mate on FreeBSD, Solaris, and A/IX (that we’ve used). It’s a neat little light-weight desktop environment.

I personally prefer Cinnamon.

IDE is with Ubuntu and Debian not usable, but it seems to work with Suse- ams Mageia-Linux.