IDE Memory leak still there

Run (toolbar |> button), stop (the round button), Run (toolbar |> button), stop (the round button), Run (toolbar |> button), stop (the round button) etc…

over and over…

No debug messages, just a empty Desktop project.

What state is your IDE in, what windows/panes are open?

again, i just open xojo then run a new desktop project. That’s it… nothing fancy. A single IDE window showing the Window 1 layout.

No library/inspector visible?

Yes the default. it shows the inspector.

I’m just not seeing it, I’ve done about 40 runs now and it’s settling around 392MB and it always returns there after a short pause when stopped.

32-bit builds or 64-bit builds? maybe it may be different?

I’ve tried both 32 and 64, after a further 20-30 runs since I last posted my memory usage is still 392MB.

Of course, if @JulianS doesn’t see the problem, it’s fairly possible Xojo has the same setup and won’t see the problem either.
It’s crucial to have an environment where the problem is reproducible, else Xojo will just close the feedback case; has anyone tried in a test computer with an out-of-the-box Xojo installation?

Seems strange. I’ll try to see how i can get it to not leak as that seems to be harder for me than leaking. I’ll do some more tests.

What version of Xojo are you using? there was a crippling mem leak in the linux Xojo IDE up until 2020r2 I think it was. Super grateful it was fixed. It’s made life better! Not sure about this one though…

2020r2.1

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.