I have developed an App and want to get the GPIO modules

I have developed an Application for the Raspberry PI. It has just some UI and methods.
Now I want to get the GPIO part to be developed. I am not able to copy paste the GPIO module (or library) in to the existing application.
Can some one explain ?
What I tried are as follows:

  1. I opened the existing application
  2. I opened the GPIO libary from the Git hub
  3. I tried to copy the Gpio library in the Navigation pane
  4. When I try to paste under the Navigation pane in the existing APP the “paste” is not available

Hello Sass,

I just tried to drag-and-drop the GPIO module into the contents section and it worked.

Maybe see if this works for you?

Umm I think I have got it working. I added a module first to my Application Project.I renamed it to GPIO (same name is not needed but I used the same name) . Then I copy pasted the contents (constants, Methods, Notes, Properties) from the GPIO module (one downloaded from GitHub) into my own App under the new module GPIO.
I request some others to correct this if it is wrong. I do not want to mislead others.
Thanks

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.