Huge Memory Leak

I spend many hours a day using XOJO on a ubuntu VM. Unfortunately, I have to restart the VM every few hours as it crawls to a halt.
The VM I use has 10GB ram allocated to it, ample processors and 128mb of video memory.

Here is the cycle i go through 3 - 4 times a day.

  1. Start VM
  2. Start using Xojo
    …2 hours later
  3. Guest OS reports 2.5GB of Memory in use.
  4. Host shows that 10GB are in use.
  5. Xojo is running excruciatingly slow (due to low memory of course)
  6. Close VM and repeat.

Is anyone else having this issue? I need to gather some more data before I can make a feedback case.

Way way not enough information. I assume that Linux has something that can monitor RAM useage. When does the RAM useage of Xojo increase? In the IDE during editing? You open and close a window in the IDE? You debug something? You do a build?

For a recent problem with the IDE in 2017r3 I even wrote a tiny app to monitor the RAM of Xojo. But that was Mac only.

Yes Beatrix, I agree. I was hoping the problem was common enough, and someone with the same frustration would know exactly what I’m talking about.

Part of my problem is the RAM instruments on the guest OS are not reporting this strange memory leak. All I know so far is what I have posted. If I can nail down some more details I’ll make a feedback case.

Also, are you sure this has something to do with Xojo? Have you tried other demanding applications for hours?
The difference in memory reported by host and guest points more to a VM driver issue. What VM software are we talking about?

Which Ubuntu do you use?

did you ever find a solution to this problem?

I am running Linux Mint 18.2 64bit on a dell laptop with 8GBs of RAM and a terabyte HD. no VM involved in my case.
you can launch any of the example projects from XOJO and see the problem which is illustrated by watching the memory consumption of XOJO continue to grow over time.
it is really driving me crazy. i feel like it is probably related to some other source code or libraries that xojo uses in order to render itself in linux but who knows. i would love for someone at XOJO to take a serious look at this problem and i would also like to create a poll and ask how many folks develop with XOJO on linux and i don’t mean deploying your app on linux actually using the IDE to develop the apps on linux. the built apps run like a dream. Very fast and i am very happy with the built apps. it is using the IDE on linux that is causing me to pull my hair out.
let me know…
Thanks,
Jeff

Most important.
Think the IDE for Linux does not get much attention. My friend, also Xojo developer, tried to use it several versions, but gave up. Use the mac or windows version instead to build for Linux is my advise.

What is the VM name and version ?

What your application do ? Intensive graphics drawings, video editing, math calculations…

Is it compiled as 32 or 64 bits ?

Running in the IDE or Stand Alone application ?

Eventually, Xojo version can matters / help.

[quote=388648:@Joost Rongen]Most important.
Think the IDE for Linux does not get much attention. [/quote]
It’s too bad, i have always been a big fan of the product

It might be related to feedback://showreport?report_id=47818 47818 - A memory leak only by opening and closing windows in Linux

Unfortunately this has been open since April 2017 and hasn’t been fixed yet.

No sorry Jeff, still struggling with this one.

I use Ubuntu 16.04, perhaps an update to Ubuntu 18.04 will help but I doubt it.

Here is a active thread that goes back 5 years or so.
https://forum.xojo.com/1448-linux-ide-editor-very-slow/last

I have moved this to my top case… perhaps Xojo will give it some love.