HTTPSocket download file on XP/Win7

I need to say that I’m not that Windows savvy but I’ve bumped into a weird thing here using the HTTPSocket in Windows XP compared to Windows 7 that I can’t figure out.

HTTPSocket.Get(url, f) Works just fine on Wiwndows 7 but when I debug the exact same code on XP it returns Error 103 - NameResolutionError.
url looks something like this
f points to SpecialFolder.ApplicaionData.Child(“afolder”).Child(

Does any of you know XP can’t resolve the URL while Win 7 can?
(also works on OSX)

Maybe it’s simple and I need to sleep…;)

Could it be a DNS failure on your XP machine? Are you able to ping that host in XP’s cmd.exe using the host name? How about using its ip address? What happens if you hard-code the ip address in your Xojo code?

Try adding an entry into your hosts file on the XP box c:\Windows\System32\Driver\etc\hosts. This will bypass any DNS issues.

Thanks guys. Works now.
Forgot to mention is was a VM and it has the wrong Network Adapter settings.
I switched to Wi-Fi from Autodetect and now it works fine :slight_smile:

I knew I had to sleep :wink: