HTTPS should be simple but it isnt.

This should work but it doesnt, can someone try this and tell me what I am doing wrong.

[code]dim ht as new HTTPSecureSocket

dim res as string

res = ht.get(“”, 20)

MsgBox res[/code]


It would really help if you described what doesn’t work.

sorry -it doesn’t connect - the response is empty.
I have also tried POST but still nothing is returned

Is there a reason why you are not using the new framework?

Dim ht As New Xojo.Net.HTTPSocket

Then check HTTPStatus and content in the PageReceived handler.

The new framework HTTPSocket is handling https for you.

If you are using the URL as in your example above, then it may fail because you are not authenticated. You need to add an api key to your GET request:

Hi Oliver,
I have tried the API as well, but the same happens even with the key.
I used the above to simplify to problem.

The program I am updating is compiled using Real Studio 2012 r2.1 and would take quit a while to update to XOJO.
I will try using a recent version in the morning.


I tried using the sample for Xojo.Net.HTTPSocket and it works a expected. I might have to make an external app and call it rather than re-writting the whole program so it will run on a 2018 version.


@damon pillinger – look into ConnectionType. It may be that they’ve changed the security requirements. Also check the HTTPStatus property if you get no response. If it’s 301 (temporary) or 302 (permanent), the server is redirecting you and the header named Location will tell you where.

I checked the server and saw it is requiring the SNI extension. This is not supported by the classic SSLSocket, so you’ll not be able to get any connection with that.
The relevant Feature Request is here: <> currently on rank 46!

Hi Tobias,
thanks for the information , knew it would be something.

I am finding something weird now with Xojo.Net.HTTPsocket

this works

Dim ht As New Xojo.Net.HTTPSocket ht.send("GET","" ) AddHandler ht.pagereceived , addressOf CheckAbuselPDBpageReceived
but if I try to insert an IP address (which is passed as a parameter to the exact same method)

Dim ht As New Xojo.Net.HTTPSocket ht.Send( "GET" ,""+ip ) AddHandler ht.pagereceived , addressOf CheckAbuselPDBpageReceived
I get an error “There is more than one item with this name and it’s not clear to which this refers”

ht.Send( “GET” is highlighted in yellow.
XOJO 2018r2

also tried

dim s as string = ""+ip ht.Send( "GET" , s)

but get the same error

O.M.G. - talk about obscure
went back to the example and found this stuck next to a string name .ToText

ht.Send( "GET" ,""+ip.ToText )
And it works like a charm.

Problem solved.


now I remember why I didnt swap to Xojo 2017
Windows runtime installer is missing files.

When I run the vc_redist.x64.exe from the XOJO Extra’s folder it runs through the installation but I still get the “missing files” message.

having the 41 files in the same folder as the app is tooo ugly.

Does anyone have a simple elegant solution?
Windows 7