HTMLViewer Still broken on Jessie?

Still no luck on a fresh install of Jessie for HTML Viewer? I have the libraries installed.

Any work arounds?

It will load a local HTML file, just not a url (Exits with output “Aborted”)

PS: I’m aware of the feedback cases.

This is a bug that was found some time back and is unfortunately not on their priority list. I’ve attached a link to the bug report and while I’ve put my top Pro points towards this bug, it is still sitting at 197. It is a real show stopper from further expanding Xojo use within our Science Centre.


The XoJo HTML Viewer bug has also just bitten me as well. I am working on Desktop project for the Raspberry Pi 3 with the standard Pi 7" touchscreen. It requires access to GoogleMaps API, but the code fails miserably during LoadPage.

My research suggests I have to run Jessie in order to use the Touchscreen/Pi3 combination, so rolling back to Wheezy for this project is not an option for me.

The feedback case is now has a priority of #77, but that doesn’t really say ‘when’ (or even ‘if’) the problem will or can be solved. Are there any alternative viewers I could use with XoJo instead?

Up until now, I had spent several weeks on this project, so I don’t really want to change to another development platform if I can avoid it as I’d virtually have to start from scratch again. But this is show-stopper for me at the moment, so any suggestions would be welcome.

Warmest regards,