HTMLViewer PC Madness


I have an app with an HTMLViewer in it that opens a page on our server. The server requires a user name and password. I have this working fine on a Mac, it logs in and the correct page is displayed. I log into the server and get a key back and then send the user, password and key and load into an HTMLViewer. I have used a HTTPSecureSocket and the Get method to get the key.


As I mentioned it’s fine on a mac but it doesn’t work on a PC, I get our “incorrect username or password” page instead. As I have the username and password field there I try and log in and again I get the same error page.

I created a tiny app with just a textfield and an HTML viewer in it and pasted the URL and key into the textfield and had the button load the URL into the viewer. This works fine on a Mac and doesn’t on a PC.

I am using the latest version of XoJo and 10.12.3 OSX and Windows 10 Enterprise. I have set the HTMLViewers to WebKi and Native with no difference.

It will be something simple but I’m blowed if I can see it.



Have you tried changing the engine to “WebKit”?

Just curious are you using Basic Http Auth at all or solely a custom system? Also could you not use HTTP Socket to retrieve this key, it allows a lot more flexibility. I suffered thru similar issues and ended up going with socket instead of viewer and so glad I did.

Yes I have tried Webkit and Native and they are both have the same results.

I have retrieved the key and pasted it into a text field with the url at the front. That works on a Mac but not on the a PC.

It looks as if there is an issue with opening this particular https site with the Xojo HTMLViewer on a PC and not on a Mac. I suppose I’m curious as to if this is a know issue?

On PC you can also use the Active X Microsoft Web Browser (menu insert)


That may be an option but how do I use that in Xojo?


If you use native renderer, Xojo internally uses this WebBrowser control from Microsoft as far as I know.

[quote=336275:@Nigel Edwards]Hi,

That may be an option but how do I use that in Xojo?


Menu Insert
Insert Active X
Microsoft Web Browser
Then it shows up as a control.

I posted a link to the methods and properties of that control.