HTMLViewer not showing remote CKEditor images

I’n not sure if anyone can help but:

Something seems to have changed with HTMLViewer in more recent versions on Xojo that hinder CKEditor from displaying online images. It cannot be the version of macOS since the HTML displays the image correctly in an older version of an application (see below the TimeCache logo displays correctly in the top-right):

I have tried both newer versions of CKEditor, and the version extracted from the application above, in later versions (Xojo 2018 Release 4, Xojo 2019 Release 1.1) but the image shows as an outline only. I have tried setting the HTMLViewer as Native or WebKit, to no avail. All the other buttons in CKEditor work fine. Here is how it looks:

It displays fine in Safari:

Here is a sample Xojo application with the CKEditor files and sample HTML text I load:

Any help would be appreciated!

Don’t you need to set the transport security thing?

Hi David,

I tried your sample app and confirm the behaviour, image not showing.

Seeing your project is 64bits I tried to compile in 32bits and this solve the problem …
Changing the settings back to 64 bits, re-compile and it’s still working fine …

I tried with my gHTML Editor Xojo Add-on, which is 32 bits as default. And I can display an image.
If I compile 64 bits the image doesn’t show up.
Back to 32 bits, it’s still ok, back to 64 bits again and it’s fine …

This is really weird.

Try yourself:

  • change your sample app to 32 bits, run; should be ok
  • change back to 64 bits, run; should be still ok

I’ll dig deeper later and report if I find something.

FWIW: It seems to work in the desktop version, as far as I see.

I’m currently working on an app where I use ckeditor to create seminar descriptions in html, which then are sent to Wordpress.
I’m using gHTMLdesktop version 1.3 of Olivier Colard, with Xojo 2019r1.1 (64bit)

See picture displaying on screenshot (picture is on the webserver, on WordPress Media library)

I did a small test app with a HtmlViewer, without CKEditor, the problem is the same.

It depends on 32/64 bits and on the image origin http/https, but there’s a difference between macOS and Windows
I’m using the following image:

Run the sample app in 32 bits and the again in 64 bits, mac and Windows.

The image with httpS:// shows correctly in both 32-64 bits.
The image with http:// doesn’t show in 64 bits

Windows 10:
Both http and https images are showing correctly, 32 and 64-bits using native renderer.
Using webkit both images are showing but are ugly ;-(

Sample app here

@Olivier Colard Changing from 64-bits to 32-bits (it ran properly) then back again worked! But now I don’t understand why that should make any difference, as it is a bit scary that is does! I hope this will ‘stick’ after saving/reloading too!

@Oliver Osswald I have bought and used gHTML for the web, but not for desktop. It is good, but still uses CKEditor behind the scenes. I have purchased a separate CKEditor licence since I want to be able to determine exactly what ribbons I include (or not, as many don’t work in desktop apps).

Do I conclude that this is a 64-bit, http macOS issue or a Xojo HTMLViewer issue?

Looks like there is a Feedback issue (not CKEditor-based) already: