How to use the free Linux build?

How can I build a Linux version with the free linux license? I installed Xojo 2024_1, but when I try to build a Linux version from my project, it asks me to buy a Linux license.

1 Like

Maybe… ask Xojo for a free license (as it was long time ago).

Nope :slight_smile:

Taken from the official Blog: Version Control Ready Xojo Lite and Free Xojo Linux Lite for Everyone – Xojo Programming Blog

Launch Xojo 2024r1 and open any desktop or console project, go to Build Settings, select Linux and in the Inspector choose the appropriate Architecture that matches the Linux OS you want your app to work on, either ARM or x86. Click Build to compile your project to a standalone app that you can then run on Linux – no license required.

Looks like it’s not even possible anymore to buy a Linux Lite Version:


I did all that, clicking Build, I get this:

Maybe it’s better do do as @Emile_Schwarz recommended.
Either there is an error in the current release or the text in the blog (and shop?) should be updated. :slight_smile:

In the IDE, are you logged in? Do you have any license in the license list that could be conflicting?

I think in this case it will be easier to help you by email (

Thanks, I will send you a mail.

I tried to open my account on the website, but I cannot log in. I get this error:
Screenshot 2024-03-27 at 11.03.06

Does Xojo list your licenses?
What license (if any) do you have?
Are you working on Windows, Linux or Mac?
Are you building a Linux Desktop project?
Besides Linux, do you have a checkmark in any other platform to build?

My experience: I have a Web license for work, downloaded 2024r1, created a new Desktop project, clicked Linux and Build complained that I need a license (because the project had a checkmar on ‘This computer’), made sure that only build target was Linux and Xojo build the project for Linux (from a Mac with a Web license only).


Yes, Xojo lists my MacOS license.
I am not specially building a Linux project, but have my MacOS desktop project open while trying to build the Linux version. I tried it also with a Linux project from the examples, but it still asks me to buy a license.
Yes, I have the This Computer platform checked. I unchecked it and indeed, now it builds the Linux version. Why would this be a problem for building the Linux? But now it works, thanks!

Your Mac license is current? (as in, it allows builds with 2024r1 for mac?)
If your license is no longer current and you have ‘this computer’ selected then it makes sense for Xojo to remind you that you need to renew your license to build for Mac.

Getting this error means something in your project requires a Desktop license to build. The free Linux option will only build an app that could be previously build using Linux Lite, so you are limited by the restrictions of a Lite license. Are you using a database other than SQLite? Are you using Worker? Are you trying to build for anything other than Linux without a license for that, like for example, macOS or Windows too?

1 Like

I only have an MacOS desktop license for which I always build successfully. Adding the Linux check gives the question to buy a license, so this Build Settings check asks for a license, without the Linux check it works normally:

Screenshot 2024-03-27 at 15.46.01

Hi Andre, So you have a Mac Lite license? Are you using a db other than SQLite? What machine are you on? I apologize if you have answered these above. Of course you can email me at if that’s easier than going back and forth here.

Because you were asking it to build two versions.

It’s a bug. Some case not addressed. According to the announcement, selecting Linux as target should not cause that in any combination with other licensed targets. Surely tied to the limits of a light version. You’ve proven it works if you uncheck your light licensed platform. Seems that Xojo is doing something like adding +1 to the number of targets selected (resulting 2) and comparing to you license (that allows 1). If that is the case, they must change the way they handle that.

Updating this thread with the Issue:
#75973 - Lite License bug - building for Linux