How to state Mac Desktop App Requirements

I’m trying to figure out how best to present to users the system requirements necessary for a Mac Desktop app I just built using the latest Xojo 2016r11. I found this page:

http://developer.xojo.com/system-requirements

…and on that page, it shows the following info showing for which versions of Mac OSX a program built with Xojo 2016r11 will work with…

“”""
OS X El Capitan 10.11.x
OS X Yosemite 10.10.5
OS X Mavericks 10.9.5
OS X Mountain Lion 10.8.52
OS X Lion 10.7.52

2 OS X 10.7 and 10.8 support is deprecated.
“”""

I’m just wondering exactly what that means and how best to present the info to prospective users of my app.

It’d be nice to say something simple like “Requires OSX 10.7 or later”, but I’m not sure that’s actually true?

What if, say, someone had OSX Mavericks 10.9.4? Would my app work for them? Or do you strictly follow the above info and say if you’re using Mavericks you MUST use the latest version of Mavericks (10.9.5)?

You might interpret the above info to mean you must always use the final version of a previous major release, but any version of the current release is OK?

Can you actually test all those MacOS versions? Everything SHOULD work on Lion. But do you really know it? As solo developer I can’t test all that. So I’m developing on the latest MacOS. Test one or two versions back. And that’s it. Everything else is for companies with more resources than I have.

At the moment I’m supporting 10.9 and higher. I add a plist entry that my app can’t be started in 10.8 or lower. My users aren’t very computer savvy. But I very rarely get requests for a version that runs on older Mac OSs.

There ?
http://developer.xojo.com/system-requirements

With Apple’s yearly OS releases, I’ve gone the same route. Only this year our base line will be 10.10. Apple have done a good job of encouraging people to update the latest OS version, especially giving it away it FREE.

Less free more “bug free” please :stuck_out_tongue:

Thanks everyone for the comments. All much appreciated. I certainly don’t test for all versions, but always felt it would be nice (if safe) to broaden the number of machines and OS versions a program should work on. Yet, I’m realizing also the ease and sense of suggesting a recent OS release as a minimum requirement…especially since OS releases have been free.

[quote=273004:@Ken Winograd]I’m trying to figure out how best to present to users the system requirements necessary for a Mac Desktop app I just built using the latest Xojo 2016r11. I found this page:

http://developer.xojo.com/system-requirements

It’d be nice to say something simple like “Requires OSX 10.7 or later”, but I’m not sure that’s actually true?[/quote]

I trust the information about minimum requirements given in the line “Desktop apps created with Xojo have these requirements” written in the link given above and tell my users the 10.7 minimum.

Probably some special characteristics would increase the system requirements,
but pure Xojo code should run with the minimum system requirements given.

While 10.7 and 10.8 is deprecated for now, at some point its support will be rmvd by Xojo,
but I must say, I don’t care about, when it’s time.

On our site I sometimes list just the mimimum version “10.10 Yosemite+” or list the min and the max “10.10 Yosemite ~ 10.12 Sierra”. Depending on how much space I have and the target audience, sometimes it’s even “10.10 ~ 10.12”.

Just because Apple and Xojo have released new versions, doesn’t mean that the old versions no longer work. And this is why I have to keep Xojo 13r3.3 around … The controlling factor for us is that we support a lot of EDU/K-12, research, and government shops where they are still using as far back as 10.6.8 (if it ain’t broke, don’t fix it). For one product, I still use 2005r1 to support a customer’s PPC systems on 10.5.8 running on a G5 Xserve farm (24 systems) and we actually have some X11-based TCL/TK running there, as well. For us, it’s more about maintaining the customer relationship, than moving to the latest technology.

Here’s our G5 build machine info:

    System Software Overview:

      System Version: Mac OS X 10.5.8 (9L31a)
      Kernel Version: Darwin 9.8.0
      Boot Volume: Mac OS X
      Boot Mode: Normal
      Computer Name: smac3 PPC
      User Name: Tim Jones (tjones)
      Time since boot: 158 days 11:30

Like I said, if it ain’t broke … :slight_smile:

The only problem with that is that systems running things as old as 10.5.8 are subject to huge security vulnerabilities that have been discovered since Apple stopped releasing security updates for those old systems.

That is how airports in France end up running Windows 3.1 and grounding all planes :wink:

Except that these systems are not used for internet access or public access. We don’t question the customers’ wont to continue using the old systems, we simply insure that we’re the solution provider that they continue to utilize for their backup and archival needs.

As we’ve had to learn the hard way in the recent years, keeping systems up to date is only sane as long as the company that develops the OS cares. Once the OS vendor uses OS updates as a means of forcing users to upgrade the hardware; it becomes a shit storm.

If you absolutely don’t know what you’re doing you could always list it like today’s macZOT

_>