How to prevent confirmation when closing Web App page

I have one app that is prompting for a confirmation before closing or reloading the page. I don’t know why this app is behaving this way - is there a simple setting I must have checked off somewhere?



I’ve reviewed this - and I haven’t added any Event Handler for anything in the web session (except “Opening”).

It can be set in code, or you can set it in the IDE:

(Edit) I assume you are talking about a Web 2 app, yes?

Also, oddly the documentation says “You should only set this property in the Inspector. Changing it in code will not likely do anything.” but I’ve never done that - I’ve always set it in code, and it always works fine.

Here’s a shot of my IDE and it’s settings. Notice that none of these entries represent the text being displayed in the modal “Are you sure you want to leave this page?” dialog. And it says “Obsolete”? I’m confused.


try to set nothing inside the confirmation message property
it should not trigger the message when you close the window.

The content displayed is built-in in the browser. Whether to display a message is only related to confirming whether the message property contains characters. When the confirmation message property is empty, the confirmation message dialog box is not displayed.

Thanks @Jean-Yves_Pochez and @Vigia_Lin , leaving the value for ‘Confirm Message’ blank did in fact remove that annoying modal.

1 Like